Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] KDE4.2
  • From: Anders Johansson <ajohansson@xxxxxxx>
  • Date: Thu, 29 Jan 2009 08:21:26 +0100
  • Message-id: <200901290821.26795.ajohansson@xxxxxxx>
On Thursday 29 January 2009 07:45:35 Basil Chupin wrote:
Anders Johansson wrote:
On Wednesday 28 January 2009 02:53:40 Basil Chupin wrote:
[...[

Just remember a couple of things: 1) kde4:/factory flavour is openSUSE
development

Agh, yes, I always mix up unstable and factory. Sorry about that

I really don't recall any dependency problem but if there were then to

When going from 4.1.3 there are a few things in the popup, such as
powerdevil no longer being its own package, and a few other things

the errors reply "Ignore some dependency problems for kde4" (or close
enough to this :-) ).

Right

Anders

What has me "confus-ed" (as my late father-in-law used to say [he was
Italian]) is that this morning more updates were reported by zypp (or is
it zypper?) and when I went to apply them I suddenly (as in yesterday or
day before there were none) got a dependency error which I satisfied by
not installing compiz-kde-4-0.7.8.24.1.

Then I decided to install smart as the system updater (I have it
installed on my "test" system" with the identical (naturally) channels
(repositories) I have for zypper/zypp/whatever).

Not only did smart have any problems with dependencies associated with
compiz-kde-4* (above) it installed about a dozen updates - even though
zypper/zypp was showing no updates to be done only a minute or so before
I ran smart.

Results like this don't make for trust about whether oS is being
correctly updated. Personally I cannot help accept smart as the more
reliable app to update oS.

It's hard to comment without knowing the details of your dependency issues. It
could be simply that your first update attempt was in the middle of a sync, and
when you tried again it was finished.

There were dependency issues when going from 4.1.x to 4.2 (your last update
from 4.2RC to 4.2 final was long after that, you must have handled those issues
long before)

I know that smart at least in the past had issues with 64 bit machines, when
the repositories weren't completely in sync and 32 bit packages had higher
version numbers, it would suddenly start migrating your system to 32bit,
messing everything up in the process. Has that been fixed now?

But if you see something in zypper that strikes you as a bug, report it. It
must be fixed

Anders
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >