Mailinglist Archive: opensuse-translation-es (174 mails)

< Previous Next >
Re: [opensuse-translation-es] [Bug 350693] translation patch for de, es, fi, ja, pt_BR (fwd)
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Fri, 18 Jan 2008 11:57:03 +0100 (CET)
  • Message-id: <alpine.LSU.1.00.0801181135570.29430@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Content-ID: <alpine.LSU.1.00.0801181137390.29430@xxxxxxxxxxxxxxxx>


El 2008-01-17 a las 20:46 +0100, Miguel Angel Alvarez escribió:

Se trata del fichero
"/usr/share/update-desktop-files/locale/translations_es/en_US/LC_MESSAGES/e
ntries.mo", que es un symlink a
"../../../../../locale/es/LC_MESSAGES/desktop_translations.mo"
Es parte del rpm update-desktop-files.
Este fichero no está incluido en el parche que han publicado.


Creo que el efecto debiera ser inmediato, pero igual no y hay que usar
ese script :-?

El script solo sirve para crear rpms, es decir, cuando construyes un rpm se
aplica el update-desktop-files a los .desktop que van a ir en el rpm, no a
los que hay en el sistema.

Ah.

Tendremos que sacar un parche para el update-desktop-files.rpm, para que los
rpm construidos en el sistema salgan bien, Y otro(s) parche(s) para
los .desktop del sistema (los que consideremos importantes, por ejemplo yast,
services de konqueror, k3b, etc). Como alternativa al parche para
los .desktop del sistema, se podría sacar un script de actualización de
los .desktop del sistema, pero no me gusta mucho la idea porque entonces los
md5 de los .desktop no coincidirían con los almacenados en la base de datos
rpm, lo que cuando menos es un tanto chapucero.

Tengo una idea, y es que ese ficherito tiene dos (no se si más) personalidades. Una es "entries.mo", y otra desktop_translations.mo. Una será usada por el script que dices, quizás, pero puede que otro programa o programas lo usen. Debería usarse al crear las entradas de menú, ¿no?

Estoy pensando en los nombres de los módulos del Yast, que salen de ese fichero.




De todas maneras, a mí todavía no me ha aparecido en el YOU, sólo el krb5,
tendré que esperar a que se propague por los mirrors.

Ahora me ha aparecido: translation-update (que el sumario dice que es para SLE) y yast2-trans-de.

Y me da un conflicto:

#### YaST2 conflicts list - generated 2008-01-18 11:42:31 ####

atom:yast2-trans-es cannot be installed due to missing dependencies
There are no installable providers of yast2-trans-es >= 2.15.7-3.1 for
atom:yast2-trans-es-2.15.7-3.1.noarch[gwdg-update]
=== atom:yast2-trans-es-2.15.7-3.1.noarch[gwdg-update] ===
atom:yast2-trans-es-2.15.7-3.1.noarch[gwdg-update] is needed by
patch:yast2-trans-de-4889-0.noarch[gwdg-update] (yast2-trans-es == 2.15.7-3.1)
(null)
Conflict Resolution:
( ) Install yast2-trans-es although it would change the vendor
yast2-trans-es-2.15.7-3.1.noarch[gwdg-update] provides this
dependency, but would change the vendor of the installed item
( ) do not install yast2-trans-es
do not install atom:yast2-trans-es-2.15.7-3.1.noarch[gwdg-update]
( ) Ignore this requirement just here

#### YaST2 conflicts list END ###


Ah, vale, ya se lo que es... tiene conflicto con MI yast2-trans-es-2.15.6-900, que me generé yo mismo con checkinstall para probar las traducciones. Lo gracioso del caso es que el informe de conflicto no dice cual es el paquete instalado, cuyo nombre ayudaría a saber de que va el tema.

Ya tengo otro bugzilla al canto ;-)


- -- Saludos
Carlos E.R.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.4-svn0 (GNU/Linux)

iD8DBQFHkIYCtTMYHG2NR9URArkwAJ4wogGkDjcqUrCDufmyLUD9ARuJTQCggF0T
7CorVTG8IuAWbNo50A9+v/M=
=WOJw
-----END PGP SIGNATURE-----
< Previous Next >