Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
[opensuse-packaging] apache2-mod_authnz_external depending on Apache version
Hi,
this is probably answered before, but I didn't find anything in the
archives and Packaging Guidelines.

apache2-mod_authnz_external comes upstream in different versions for
different apache versions:
3.3.x is for Apache 2.3/2.4
3.2.x is for Apache 2.2

Currently in https://build.opensuse.org/project/show/Apache:Modules we
have version 3.2.6, working and compiling only for apache 2.2.
So it does not build for newer distros, i.e. openSUSE 13.1 and newer.

I branched and updated my branch to 3.3.2. It builds for the openSUSE 13.1
and newer and for most Apache_* targets.

What is the best way to bring 3.2.6 for older distros and 3.3.2 for newer
distros to the Repositories?

I thought about including version number in the package name. That would
probably mean to also change name of the existing package?

Is there is a way to build different versions depending on either
distribution/repository or even better depending on apache version?

TIA.
--
Mit freundlichen Gruessen,
Andreas Vetter

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups