PMing maintainers, too
Jan Engelhardt <jengelh(a)inai.de> wrote on 30/01/2014 17:21:11:
On Wednesday 2014-01-29 09:53,
this is probably answered before, but I didn't find anything in the
archives and Packaging Guidelines.
apache2-mod_authnz_external comes upstream in different versions for
different apache versions:
3.3.x is for Apache 2.3/2.4
3.2.x is for Apache 2.2
Typically, there would have to be two packages that conflict with
apache2-mod_authnz_external (for 3.3), requiring apache2-mpm >= 2.4
and nothing else
Is there a reason why you use "apache2-mpm >= 2.4" instead of
"apache2 >= 2.4"
apache2-mod_authnz_external-3_2 (for 3.2), requiring apache2-mpm < 2.4
and conflicting with apache2-mod_authnz_external.
Do we really need the conflict when we have the requirement on apache
There will only be built either the old or the new module (meaning XOR).
This is (very loosely) indicated by
>I thought about including version number in the package name. That
to also change name of the existing package?
Indeed it would. (And it's just a copy of the existing package
before you SR the new version.)
I prepared both versions in OBS:
3.2.6 for apache 2.2:
3.3.2 for apache 2.4:
Are maintainers ok with that?
To unsubscribe, e-mail: opensuse-packaging+unsubscribe(a)opensuse.org
To contact the owner, e-mail: opensuse-packaging+owner(a)opensuse.org