Mailinglist Archive: opensuse-kernel (77 mails)

< Previous Next >
Re: [opensuse-kernel] scheduling while atomic with 2.6.31.8
  • From: Takashi Iwai <tiwai@xxxxxxx>
  • Date: Wed, 16 Dec 2009 11:46:15 +0100
  • Message-id: <s5hy6l3fb7s.wl%tiwai@xxxxxxx>
At Wed, 16 Dec 2009 11:41:51 +0100,
Andreas Jaeger wrote:

On Wednesday 16 December 2009 11:09:17 Takashi Iwai wrote:
At Tue, 15 Dec 2009 13:24:45 +0100,

Andreas Jaeger wrote:
I saw with 2.6.31.7 and now again with 2.6.31.8 some OOPS during boot.
Should I open a bugreport for this? Does this happen for others as well?

Did it happen with 11.2-GM kernel? If it's a regression from the
older 2.6.31, it'd be easier to find the cause.

It happens with 2.6.32 head as well.

The recent patches are also in HEAD, so no wonder :)

I don't remember seeing it earlier and I've tried kernels now:

buggy kernels:
* kernel-desktop-2.6.31.6-0.0.0.40.cf2320f.x86_64
* kernel-desktop-2.6.31.7-0.0.0.0.50b4262.x86_64
* kernel-desktop-2.6.31.8-0.0.0.0.239ecb7.x86_64
* kernel-desktop-2.6.32.1-0.0.6.63b437e.x86_64

If so, the commit below smells, judging from the stacktrace...

Tue Dec 1 16:22:31 CET 2009 - jeffm@xxxxxxxx
- patches.suse/init-move-populate_rootfs-back-to-start_kernel:
init: move populate_rootfs back to start_kernel (bnc#533555).
- patches.suse/acpi-generic-initramfs-table-override-support:
ACPI: generic initramfs table override support (bnc#533555).

That's in the 2.6.31.6 I tried.

Yep.

The GA kernel (kernel-desktop-2.6.31.5-0.1.1.x86_64.rpm) works fine (just
tested),

OK, that's good to know.

Any chance to revert the commits above? Building a local kernel
wouldn't take so much time.


thanks,

Takashi
--
To unsubscribe, e-mail: opensuse-kernel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-kernel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups