Mailinglist Archive: opensuse-factory (209 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190904 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 06 Sep 2019 03:02:03 +0000
  • Message-id: <156773892395.4506.11301460905156859365@go-agent-stagingbot-8>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190904

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
glib-networking
hplip
libgnome-games-support (1.4.3 -> 1.4.4)
libktorrent (2.1 -> 2.1.1)
libusb-1_0 (1.0.22 -> 1.0.23)
nghttp2
patterns-base
perl-YAML-LibYAML (0.79 -> 0.80)
rubygem-addressable (2.6.0 -> 2.7.0)
srt (1.3.3 -> 1.3.4)
wavpack (5.1.0~git20190420.22977b2 -> 5.1.0+71.22977b2)
webkit2gtk3 (2.24.3 -> 2.24.4)
xorg-x11-server
yast2 (4.2.18 -> 4.2.19)
zypper (1.14.29 -> 1.14.30)

=== Details ===

==== glib-networking ====
Subpackages: glib-networking-lang

- Move LICENSE_EXCEPTION to %license.

==== hplip ====
Subpackages: hplip-hpijs hplip-sane

- Renamed "hplip-scan" to "hplip-scan-utils" to express the
purpose of the package more clearly in the name.
"hplip-scan" has never been in public repos.
- Added conditional BuildRequires on "cups-rpm-helper".
Recently a bug in python-pycups was fixed that had prevented
autogeneration of Provides: tags in printer drivers by means
of "BuildRequires: python3-cups". See OBS sr#726727. This
dependency must be conditional for now, as cups-rpm-helper
is not available in every project yet.
- Ran spec-cleaner.
- Removed compatibility code for SLE12/Leap42 and earlier
As we are now using rpm 4.13 (A and B) syntax, we can't support
these any more anyway.
- Moved hp-scan and hp-uiscan to a separate package "hp-scan".
These tools pull in PIL and python3-scikit-image, which causes
a rather big dependency list, which is only available in openSUSE.
This allows us also to get rid of the non-functional "hp-scan" tool
in SLE.
- Fixed --with-htmldir so that documentation is packaged
- Improved package descriptions and summaries
* Clarified the relationship of hplip-hpijs, hplip-sane, and hplip
* Shortened the descriptions
* Removed reference to HTML documention in package description
- Added -devel dependencies as required by post-build-checks
- Minor spec file cleanup (macro usage)
- Fixed build failures on non-standard architectures by adding BuildIgnore
These failures are actually caused by some ports catching up
slowly with package updates. But our BuildIgnores are helpful
nonetheless, making the build environment leaner.

==== libgnome-games-support ====
Version update (1.4.3 -> 1.4.4)
Subpackages: libgnome-games-support-1-3 libgnome-games-support-lang

- Update to version 1.4.4:
+ Fix build with new gettext.

==== libktorrent ====
Version update (2.1 -> 2.1.1)
Subpackages: libKF5Torrent6 libktorrent-lang

- Update to version 2.1.1
* Fix HTTP seeding (kde#382375)
* Fix a few issues found by clang-tidy
* Some build fixes that get triggered on certain versions of
Qt/KF5 frameworks
- Drop fix-build-with-qt5.6.patch, merged upstream
- Drop require-lower-LibGMP.patch, no longer necessary as all
current distribution versions have gmp 6
- Remove conditionals for no longer supported distribution versions
- Add missing requirements to the devel package
- Update URL, ktorrent.org doesn't exist any more
- Run spec-cleaner

==== libusb-1_0 ====
Version update (1.0.22 -> 1.0.23)

- Update to version 1.0.23
* Core: abandon synchronous transfers when device closure is
detected.
* Core: fix error in handling the removal of file descriptors
while handling events.
* New API libusb_set_log_cb() to redirect global and per context
log messages to the provided log handling function.
* New API libusb_wrap_sys_device to allow the user to specify
the usb device to use.
* Various other bug fixes and improvements.

==== nghttp2 ====

- Conditionally remove dependecy on jemalloc for SLE-12

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-base patterns-base-basesystem
patterns-base-basic_desktop patterns-base-console patterns-base-documentation
patterns-base-enhanced_base patterns-base-minimal_base
patterns-base-sw_management patterns-base-transactional_base patterns-base-x11
patterns-base-x11_enhanced

- use obsolete_legacy_pattern macro for readability
- drop _opt patterns and integrate them into main patterns to reduce complexity

==== perl-YAML-LibYAML ====
Version update (0.79 -> 0.80)

- Remove perl-YAML-LibYAML-no-plan.patch (not used anymore)
- updated to 0.80
see /usr/share/doc/packages/perl-YAML-LibYAML/Changes
0.80 Thu 22 Aug 2019 01:17:13 PM CEST
- Fix memory leak when loading invalid YAML (PR#93 tinita)

==== rubygem-addressable ====
Version update (2.6.0 -> 2.7.0)

- New upstream release 2.7.0
* added `:compacted` flag to `normalized_query`
* `heuristic_parse` handles `mailto:` more intuitively
* refactored validation to use a prepended module
* dropped explicit support for JRuby 9.0.5.0
* compatibility w/ public_suffix 4.x
* performance improvements

==== srt ====
Version update (1.3.3 -> 1.3.4)

- Backported commit 47e5890 and 64875fa to fix CVE-2019-15784
(boo#1148844) and avoid a potential array overflow.
* Added CVE-2019-15784.patch
- Update to version 1.3.4:
+ Various bugfixes and feature enhancments.

==== wavpack ====
Version update (5.1.0~git20190420.22977b2 -> 5.1.0+71.22977b2)

- Change version to 5.1.0+71.22977b2:
+ This tarball is created from git master, which is 71 commits
AHEAD of 5.1.0; thus, 5.1.0~xxx is wrong, as this implies a
version leading up to 5.1.0. Other than that, there is no
change in the sources: it's the same commit as before
(22977b2).

==== webkit2gtk3 ====
Version update (2.24.3 -> 2.24.4)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.24.4 (boo#1148931):
+ Updated the user agent string to make happy certain websites
which would claim that the browser being used was unsupported.
+ Improve loading of multimedia streams to avoid memory
exhaustion due to excessive caching.
+ Fix display of documents with MIME type application/xml in the
Web Inspector, when loaded using XmlHttpRequest.
+ Fix a hang while scrolling certain websites which include HLS
video content (Twitter, for example).
+ Fix rounding artifacts in volume levels for media playback.
+ Fix several crashes and rendering issues.
+ Fix the build with video track support disabled.
+ Fix the build with OpenGL support disabled.
+ Fix build issue which would cause media controls to disappear
when Python 3.x was used during the build process.
+ Security fixes: CVE-2019-8644, CVE-2019-8649, CVE-2019-8658,
CVE-2019-8669, CVE-2019-8678, CVE-2019-8680, CVE-2019-8683,
CVE-2019-8684, CVE-2019-8688.
- Drop webkit2gtk3-bwo197558-hang.patch: Fixed upstream.

==== xorg-x11-server ====
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk xorg-x11-server-wayland

- added patches required for NVIDIA's PRIME render offload support,
which is available since release 435.xx:
0001-xsync-Add-resource-inside-of-SyncCreate-export-SyncC.patch,
0002-GLX-Add-a-per-client-vendor-mapping.patch,
0003-GLX-Use-the-sending-client-for-looking-up-XID-s.patch,
0004-GLX-Add-a-function-to-change-a-clients-vendor-list.patch,
0005-GLX-Set-GlxServerExports-major-minor-Version.patch

==== yast2 ====
Version update (4.2.18 -> 4.2.19)
Subpackages: yast2-logs

- yast completions have to be named after their respective command
name (bsc#1122259)
- 4.2.19

==== zypper ====
Version update (1.14.29 -> 1.14.30)
Subpackages: zypper-aptitude zypper-log zypper-needs-restarting

- Ignore SIGPIPE while STDOUT/STDERR are OK (bsc#1145521)
- Dump stacktrace on SIGPIPE (bsc#1145521)
- info: The requested info must be shown in QUIET mode (fixes #287)
- version 1.14.30


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages