Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180119 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180119

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
apparmor
digikam
empathy
frogr (1.3 -> 1.4)
gnustep-base (1.25.0 -> 1.25.1)
goffice (0.10.37 -> 0.10.38)
icewm
libindi (1.5.0 -> 1.6.2)
libmspack (0.5 -> 0.6)
libssh2_org
libzypp (17.0.5 -> 17.1.1)
polkit-default-privs
postgresql
python-decorator (4.1.2 -> 4.2.1)
python-matplotlib (2.1.0 -> 2.1.1)
qimageblitz (0.0.6 -> 0.0.6+svn1368047)
seahorse
spirv-tools
tre
vim
yast2-firstboot (3.1.17 -> 4.0.2)
yast2-online-update-configuration (3.1.6 -> 4.0.0)
yast2-storage-ng (4.0.69 -> 4.0.70)

=== Details ===

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang
pam_apparmor pam_apparmor-32bit perl-apparmor python3-apparmor

- add disable-cache-on-ro-fs.diff - disable write cache if filesystem is
read-only and don't bail out (bsc#1069906, bsc#1074429)
- add parser-write-cache-warn-only.diff to make cache write failures a
warning instead of an error (boo#1069906, boo#1074429)
- reduce dependeny on libnotify-tools (used by aa-notify -p) to "Suggests"
to avoid pulling in several Gnome packages on servers (boo#1067477)

==== digikam ====
Subpackages: kipi-plugins kipi-plugins-lang

- Add fix-font-size-in-tooltips.patch to make tooltips respect the
configured font size (kde#337243)
- Remove some no longer respected cmake options

==== empathy ====
Subpackages: empathy-lang telepathy-mission-control-plugin-goa

- Add empathy-fix-gettext-domain.patch: gschema: Fix
gettext-domain, patch from upstream stable branch.

==== frogr ====
Version update (1.3 -> 1.4)
Subpackages: frogr-lang

- Update homepage URL.
- Update to version 1.4:
+ Migrated to the meson and ninja, removed all the autotools
files.
+ Fixed integration with GNOME Software (appstream data).
+ Fixed errors loading images from certain cameras / phones
(bgo#768639, bgo#678241).
+ Raised versions for GTK+ (to 3.16) and JSON-GLib (to 1.2), for
g_autoptr.
+ Updated translations.
- Switch to meson buildsystem following upstream port: Add meson
BuildRequires and use meson macros and pass explicit options to
meson, ensure we build the features we want.
- Conditionalize handling of desktop_database_post(un) and
icon_theme_cache_post(un) in post(un) to only apply for old
versions of openSUSE.

==== gnustep-base ====
Version update (1.25.0 -> 1.25.1)

- update to 1.25.1
o Unicode fixes for characters outside the base plane
o Stubs for some new OSX methods
o Various new OSX compatibility macro and type definitions
o NSFileManager fixes and tweaks to match OSX implementation
o NSDistributedLock bugfix for pre-existing lock directories
o Alternative sort algorithms selectable at runtime
o Compatibility-related changes for environments not supporting weak
symbols
o Other more minor bugfixes and cleanups.
o As usual, this release also contains an update to include the most
recent international timezone data.

==== goffice ====
Version update (0.10.37 -> 0.10.38)
Subpackages: goffice-lang libgoffice-0_10-10

- --with-pic has no effect with --disable-static, so drop it.
- Update to version 0.10.38:
+ Avoid a few dubious uses of deprecated gtk+ functions.
+ Reduce number of compiler warnings.
- Use plain make call again, fix build for old versions of
openSUSE.

==== icewm ====
Subpackages: icewm-config-upstream icewm-default icewm-lang icewm-lite

- Change the recommend xlockmore to xscreensaver( bsc#1074932 ).

==== libindi ====
Version update (1.5.0 -> 1.6.2)
Subpackages: libindi-devel libindiAlignmentDriver1 libindidriver1

- Update to version 1.6.2:
* Another quick release to fix missing cmake_modules directory
and a joystick driver crash fix.
From version 1.6.1:
* This is a bugfix patch release that resolves problems with INDI
version in INDI API.
From version 1.6.0:
* INDI Base Client is now supported on Windows, MacOS, and Linux.
* Added 10Micron Mount support.
* Added spectrum support and libDSPAU.
* Added NexDome support.
* Added Pyxis Rotator support.
* Added Pegasus Focuser support.
* Added MBox Weather box support.
* Added SnapCap dust cap and flat panel support.
* Added Sesto-Senso focuser support.
* Added USB_DewPoint support.
* Added GPS-NMEA sources support.
* Added Gemini Telescope Design Integra85 Focusing Rotator WIP
support.
* Added Lunatico's Armadillo and Platypus support.
* Video Streaming support for MacOS.
* Video Recording with libtheora (Optional).
* Video Streaming with MJPEG encoder.
* IOptron fixes and improvements.
* More NextstarEvo improvements.
* Dedicated Guider Simulator.
* QHY & ASI updated to latest SDK.
* Apogee fixes for MacOS.
* INova fixes and improvements. Updated SDK.
* QHY, Apogee, DSI builds for MacOS.
* EQMod Horizon fixes.
* Skywatcher Alt-Az Mount & Syncscan fixes and improvements
including guide support.
* StarSense support in Celestron Driver.
* Improvements to mount parking & unparking.
* New experimental Astrophysics Driver.
* Support for Losmandy UDP protocol.
* Fixed Dome slaving slew and tracking.
* Added Radio Antenna Simulator.
* New INDI Rotator Interface.
* UDEV rule to disable automount of DSLR cameras.
* Sky Quality Meter simulator.
* Improvements to INDI GPS drivers.
* TCFS Fixes.
* SkySensorPC2000 fixes.
* Fixed WatchDog behavior in case of unavailable dome.
* Improved Continuous Integration support with Travis & CircleCI
using Docker.
- Drop cmake_modules.tar.gz, no longer necessary

==== libmspack ====
Version update (0.5 -> 0.6)

- Correct SRPM group.
- Fix typo
- Update to version 0.6
* read_spaninfo(): a CHM file can have no ResetTable and have a
negative length in SpanInfo, which then feeds a negative output
length to lzxd_init(), which then sets frame_size to a value of
your choosing, the lower 32 bits of output length, larger than
LZX_FRAME_SIZE. If the first LZX block is uncompressed, this
writes data beyond the end of the window.
This issue was raised by ClamAV as CVE-2017-6419.
* lzxd_init(), lzxd_set_output_length(), mszipd_init(): due to the
issue mentioned above, these functions now reject negative lengths
* cabd_read_string(): add missing error check on result of read().
If an mspack_system implementation returns an error, it's
interpreted as a huge positive integer, which leads to reading
past the end of the stack-based buffer.
This issue was raised by ClamAV as CVE-2017-11423
- Add subpackage for helper tools
- Run spec-cleaner

==== libssh2_org ====

- Drop openssh BuildRequires: this is only used for one of the
minor self-tests.

==== libzypp ====
Version update (17.0.5 -> 17.1.1)

- Adapt rpm package verification to changes in rpm-4.14 (bsc#1076018)
- version 17.1.1 (0)
- plugin: don't reject header values containing a ':' (bsc#1074687)
- Locks: Don't store duplicate locks (bsc#969569)
- version 17.1.0 (0)

==== polkit-default-privs ====

- polkit-default-privs: adding new udisks2 rules (bsc#1073216)

==== postgresql ====
Subpackages: postgresql-contrib postgresql-devel postgresql-docs
postgresql-server

- postgresql-script: /etc/sysconfig/language is deprecated, use the
locale that was inherited from systemd instead for initializing
a new database instance (boo#1074988).

==== python-decorator ====
Version update (4.1.2 -> 4.2.1)
Subpackages: python2-decorator python3-decorator

- specfile:
- updated copyright year
- updated to version 4.2.1:
* Fixed a regression breaking IPython reported by
https://github.com/spapini .
- changes from version 4.2.0 :
* Added a facility to define families of decorators (aka decorators
with arguments) as requested by several users. Accepted a pylint
patch by David Allouche.

==== python-matplotlib ====
Version update (2.1.0 -> 2.1.1)
Subpackages: python3-matplotlib python3-matplotlib-cairo
python3-matplotlib-gtk3 python3-matplotlib-tk

- dependency changed to python-six >= 1.10
(see "site-packages/matplotlib/__init__.py", line 187)
- update to version 2.1.1:
* The first and only planned bug-fix release for the 2.1 series.
* This release include many bug and documentation fixes. Highlights
are:
+ change default logscale behavior to clip
+ fixed webagg import errors
+ tweaks to polar ticks
+ fixed exception when guessing afm family names
+ update manifest to include all doc files
+ improve masked array handling in pcolormesh
+ fix segfault from reading invalid png
+ fix blocking_input
+ fix bug resulting in huge multi-page pdf files
+ make `show` in nbagg take args as other backends do
+ several fixes to OSX backend
+ restore positional arg handling on Figure.legend
+ fix bugs in interactive navigation
+ fix issues when panning with invalid limits
+ fix bug with fully masked arrays passed to imshow

==== qimageblitz ====
Version update (0.0.6 -> 0.0.6+svn1368047)

- Update to version 0.0.6+svn1368047:
* Apply some more GCC flags also on GNU/Hurd.
* Use the autodetected CMAKE_C_COMPILER instead of hardwired GCC.
Fixes build with compilers other than GCC.
* Merge Fedora's patch for non-executable stack (makes SELinux
happier).
* Add a minimum cmake version.
* Remove this outdated FindQt4. cmake 2.6.4 has a way better one.
* "comparison is always true due to limited range of data type",
which means some compiler could have made that loop run
endless.
* Port away from Qt3Support
* Enable compilation with Qt5, but skip cpptoxml.
- Remove qimageblitz-0.0.4-noexecstack.patch: fixed upstream.
- Add qimageblitz-qt5-fix-soname.patch: Change the soname for Qt5
to fix a conflict with Qt4.
- Build for Qt5 too.
- Rename the source package to qimageblitz from libqimageblitz4.
- Move the docfiles from the devel package to the library package.
- Spec cleanup.

==== seahorse ====
Subpackages: gnome-shell-search-provider-seahorse seahorse-lang

- Add seahorse-gpg-ignore-key-considered.patch: ignore new
key_considered line (bgo#779607).
- Add seahorse-new-gnupg.patch: Mark gnupg 2.2.x as supported, so
that our builds enable gpg again (bsc#1075928).
- Drop seahorse-allow-deprecated.patch: seahorse builds without it.

==== spirv-tools ====

- Make sure to build just with python3
- Remove needles buildroot variable and default defattrs
- Use autopatch to apply patches

==== tre ====
Subpackages: agrep libtre5 tre-lang

- CVE-2016-8859.patch: Fix multiple integer overflows which allowed
attackers to cause memory corruption via a large number of (1) states or
(2) tags, which triggered an out-of-bounds write (bnc#1005483)

==== vim ====
Subpackages: gvim vim-data

- Sort with spec-cleaner
- Add conditional to build with python2 in order to build with py3
only enviroment
- Convert dependencies to pkgconfig style

==== yast2-firstboot ====
Version update (3.1.17 -> 4.0.2)

- Do not initialize firstboot in AutoYaST upgrade mode.
(Additial fix for bnc#1075744)
- 4.0.2
- Bring back HostnameDialog adding it into firstboot_hostname once
it was removed from yast2-network (bsc#1028371, bsc#1070388).
- 4.0.1
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468).
- 4.0.0

==== yast2-online-update-configuration ====
Version update (3.1.6 -> 4.0.0)

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468).
- 4.0.0

==== yast2-storage-ng ====
Version update (4.0.69 -> 4.0.70)

- Correctly open the expert partitioner when called from the
Kubic/CaaSP summary screen (bsc#1076732)
- 4.0.70


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages