Mailinglist Archive: opensuse-factory (537 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171031 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171031

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
cyrus-imapd
harfbuzz (1.5.1 -> 1.6.3)
iio-sensor-proxy
konqueror
obs-service-set_version (0.5.6 -> 0.5.7)
postfix (3.2.3 -> 3.2.4)
powerdevil5
virt-manager
virtualbox

=== Details ===

==== cyrus-imapd ====
Subpackages: cyradm perl-Cyrus-IMAP perl-Cyrus-SIEVE-managesieve

- Removed "cyrus-imapd-2.4.19_drac_auth.patch" and dropped drac
from the BuildRequires. DRAC's upstream is bascially dead nowadays,
and the drac patch in cyrus-imapd is also largely unmaintained.
Rebased cyrus-imapd-2.4.17_openslp.patch and
cyrus-imapd-2.4.19_autocreate-0.10-0.patch as a result of the
removal.

==== harfbuzz ====
Version update (1.5.1 -> 1.6.3)
Subpackages: harfbuzz-devel libharfbuzz-icu0 libharfbuzz0 libharfbuzz0-32bit

- Update to version 1.6.3:
+ Fix hb_set_t some more. Should be solid now.
+ Implement get_glyph_name() for hb-ot-font.
+ Misc fixes.
- Changes from version 1.6.2:
+ Yesterday's release had a bad crasher; don't use it
(gh#behdad/harfbuzz#578).
- Changes from version 1.6.1:
+ Don't skip over COMBINING GRAPHEME JOINER when ligating, etc
(gh#behdad/harfbuzz#554).
+ Faster hb_set_t implementation.
+ Don't use deprecated ICU API.
+ Fix undefined-behavior in Myanmar shaper, introduced in 1.6.0.
+ Deprecated API: hb_set_invert().
- Changes from version 1.6.0:
+ Update to Unicode 10.
+ Various Indic and Universal Shaping Engine fixes.
+ Implement Unicode Arabic Mark Ordering Algorithm UTR#53.
+ Implement optical sizing / tracking in CoreText backend, using
new API hb_font_set_ptem().
+ Allow notifying hb_font_t that underlying FT_Face changed
sizing, using new API hb_ft_font_changed().
+ More Graphite backend RTL fixes.
+ Fix caching of variable font shaping plans.
+ hb-view / hb-shape now accept following new arguments:
o --unicodes: takes a list of hex numbers that represent
Unicode codepoints.
+ New API: hb_face_get_table_tags(), hb_font_set_ptem(),
hb_font_get_ptem() and hb_ft_font_changed().
- Drop pkgconfig(gobject-2.0) BuildRequires: not needed/used.

==== iio-sensor-proxy ====

- Add iio-sensor-proxy-revert-cast-align-warnings-arm-fix.patch
Revert "iio-buffer-utils: Fix cast-align warnings on ARM"
because it caused rotations on all devices to have undefined
values; patch taken from upstream (boo#1061190,
gh#hadess/iio-sensor-proxy#191).
- Add relevant package Group for both iio-sensor-proxy
(System/Monitor) and iio-sensor-proxy-doc (Documentation/HTML).

==== konqueror ====
Subpackages: konqueror-devel konqueror-lang

- Don't try to install Home.desktop in /usr/share/applications,
the copy from plasma5-workspace (by kio_desktop) should be used
instead (boo#1058743)
- Update to 17.08.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.08.2.php
- Changes since 17.08.1:
* None
- Update to 17.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.08.1.php
- Changes since 17.08.0:
* None
- Update to KDE Applications 17.08.0
* New feature release
* https://www.kde.org/announcements/announce-applications-17.08.0.php
- Changes since 17.04.3 :
- Too many changes to list here
- Update to KDE Applications 17.07.90
* KDE Applications 17.07.90
* https://www.kde.org/announcements/announce-applications-17.07.90.php
- Update to 17.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.3.php
- Changes since 17.04.2:
* None
- Recommend dolphin-part to make file management work out of the
box (boo#1047665)
- Update to 17.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.2.php
- Changes since 17.04.1:
* None
- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix build with Qt 5.9 (kde#377490)
- Update to 17.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.0.php
- Changes since 17.03.90:
* None
- Update to 17.03.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04-rc.php
- Changes since 17.03.80:
* Port kde4_add_app_icon to ecm_add_app_icon
* Save/restore window size
* Accept single line command options like we used to do
- Update to 17.03.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.03.80.php
- Changes since 16.12.3:
* Too many changes to list here
- Update to 16.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-16.12.3.php
- Changes since 16.12.2:
* rename define, to match kdepim
- Update to KDE Applications 16.12.2
* KDE Applications 16.12.2
* https://www.kde.org/announcements/announce-applications-16.12.2.php
- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php
- Update to KDE Applications 16.12.0
* KDE Applications 16.12.0
* https://www.kde.org/announcements/announce-applications-16.12.0.php
- Recommend kwebkitpart again instead of webenginepart for now, the
latter crashes currently with Qt 5.7.1 (same reason as
QTCREATORBUG-17296) and still lacks some KDE integration (e.g.
storing passwords in kwallet, kde#372777)
- Update to KDE Applications 16.11.90
* KDE Applications 16.12.0 RC
* https://www.kde.org/announcements/announce-applications-16.12-rc.php
- Update to KDE Applications 16.11.80
* KDE Applications 16.12.0 Beta
* https://www.kde.org/announcements/announce-applications-16.12-beta.php
- Update spec-files to be consistent wiht KA

==== obs-service-set_version ====
Version update (0.5.6 -> 0.5.7)

- Update to version 0.5.7:
* workaround for python3 locale problems in factory
* add a hint to flake8
* satisfy flake8
* skip also sha256sums check for Arch

==== postfix ====
Version update (3.2.3 -> 3.2.4)
Subpackages: postfix-doc

- update to 3.2.4
* DANE interoperability. Postfix builds with OpenSSL 1.0.0 or
1.0.1 failed to send email to some sites with "TLSA 2 X X" DNS
records associated with an intermediate CA certificate. Problem
report and initial fix by Erwan Legrand.
* Missing dynamicmaps support in the Postfix sendmail command.
This broke authorized_submit_users settings that use a
dynamically-loaded map type. Problem reported by Ulrich Zehl.

==== powerdevil5 ====
Subpackages: powerdevil5-lang

- Recommend upower, to ensure it is installed for battery
and brightness detection (boo#1065650, boo#1065642)

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Upstream bug fixes (bsc#1027942)
9a9f9ecd-ignore-comments-in-keymap-conf-files.patch
9617d126-systray-Use-APPLICATION_STATUS-for-appindicator.patch
e73abe5a-diskbackend-convert-to-long-the-calculated-size.patch

6e6f59e7-diskbackend-get-a-proper-size-of-existing-block-device-while-cloning.patch
23aaf852-network-Set-bridge-name-to-None-instead-of-blank.patch
d1e1cf64-progress-remove-trailing-white-space.patch
63fce081-pycodestyle-Use-isinstance-for-type-checking.patch
08a58d61-pycodestyle-remove-description-of-fixed-errors.patch
bc3c9a9d-progress-remove-unused-import.patch
2d276ebe-progress-dont-overwrite-format.patch
e2ad4b2f-convert-iteritems-to-items.patch
dff00d4f-remove-deprecated-statvfs-module.patch
75210ed3-replace-StringIO-with-io.patch
a2bcd6c4-dont-compare-between-None-and-int.patch
44de92b7-use-reload-from-imp-module.patch
69c84bea-import-reduce-from-functools-module.patch
37ea5207-replace-StandardError-with-Exception.patch
f41aafc7-Use-enumerate-instead-of-range-and-len.patch
91c0669c-cli-Fix-OrderedDict-mutated-during-iteration-on-python3.patch
b8fa0c6b-xmlnsqemu-order-XML-output-like-libvirt-does.patch
d2648d81-virtconv-dont-implicitly-depend-on-dict-hash-order.patch
999dbb36-cli-Make-VirtCLIArgument-instantiation-less-crazy.patch
7f1b4cee-pycodestyle-fix-all-E125-warnings.patch
d82022bd-manager-drop-python2-only-cmp-usage.patch
374a3779-urlfetcher-write-test-file-as-binary-content.patch
f7c8cf9f-devicepanic-dont-return-empty-model-list.patch
3be78d1f-addhardware-dont-allow-panic-option-where-not-supported.patch
73de8285-systray-remove-redundant-variable-assignment.patch

==== virtualbox ====
Subpackages: virtualbox-host-kmp-default virtualbox-qt

- Add patch to handle LEAP 15 API change in wait queues. This change addresses
boo#1064524.
File "fixes_for_leap15.patch" is added to accomplish this task.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages