Mailinglist Archive: opensuse-factory (824 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171029 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171029

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
libqt5-qtbase
netcdf
permissions (20170928 -> 20171025)
python-qt5
sddm

=== Details ===

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent-devel libQt5Concurrent5 libQt5Core-devel
libQt5Core-private-headers-devel libQt5Core5 libQt5DBus-devel libQt5DBus5
libQt5Gui-devel libQt5Gui-private-headers-devel libQt5Gui5 libQt5Network-devel
libQt5Network5 libQt5OpenGL-devel libQt5OpenGL5 libQt5PlatformHeaders-devel
libQt5PrintSupport-devel libQt5PrintSupport5 libQt5Sql-devel libQt5Sql5
libQt5Sql5-mysql libQt5Sql5-postgresql libQt5Sql5-sqlite libQt5Sql5-unixODBC
libQt5Test-devel libQt5Test5 libQt5Widgets-devel libQt5Widgets5 libQt5Xml-devel
libQt5Xml5 libqt5-qtbase-common-devel libqt5-qtbase-devel
libqt5-qtbase-platformtheme-gtk3

- Update 0001-QSslSocket-OpenSSL-1.1-backend.patch from git

==== netcdf ====

- Fix botched dependency for libpnetcdf-<mpi-flavor>.

==== permissions ====
Version update (20170928 -> 20171025)

- Update to version 20171025:
* Stricter permissions on cron directories (paranoid) and stricter
permissions on sshd_config (secure/paranoid)

==== python-qt5 ====
Subpackages: python-qt5-utils python2-qt5

- add configure_py_Fix_handling_of_disabled_features.patch
configure.py is broken if features are disabled, which e.g. happens
when building using GLEs Qt5 builds. Taken from upstream
developement snapshot.

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Add "Requires: xdm" because sddm.conf references the files
'/etc/X11/xdm/Xsession' and '/etc/X11/xdm/Xsetup'


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages