Mailinglist Archive: opensuse-factory (603 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170712 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170712

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
NetworkManager (1.8.0 -> 1.8.2)
akregator
apr
autogen
babl (0.1.26 -> 0.1.28)
bash-completion (2.5 -> 2.7)
bluez
ceph (12.1.0+git.1498654198.20d6a47cc9 -> 12.1.0+git.1499090920.2c11b88d14)
cmpi-provider-register
corosync
cyrus-imapd
dolphin
expat (2.2.0 -> 2.2.1)
flex (2.6.1 -> 2.6.4)
fontconfig
gconf2-branding-openSUSE (42.1 -> 42.3)
glabels
grub2
hwdata (0.301 -> 0.302)
iio-sensor-proxy (2.1 -> 2.2)
kdeconnect-kde
kio-extras5
kmod (23 -> 24)
konqueror
konsole
kwin5 (5.10.3 -> 5.10.3.1)
latex2html (2016 -> 2017.2)
libdiscid (0.6.1 -> 0.6.2)
libfabric
libkexiv2
libmcrypt
libpsm2
libquicktime
libvirt (3.4.0 -> 3.5.0)
llvm3_8
logrotate (3.11.0 -> 3.12.3)
marble
mercurial (4.2 -> 4.2.2)
obs-service-set_version
okteta
opencv
openmpi
openssl-1_0_0
patterns-devel-C-C++
plasma5-workspace
procps
psmisc
python-certifi
python-pywbem
python-rpm-macros (2017.06.21.6641889 -> 2017.06.29.107ac7a)
qhull (2012.1.2 -> 2015.2)
rdma-core
screen (4.5.1 -> 4.6.1)
sddm
shared-mime-info
subversion (1.9.5 -> 1.9.6)
unzip
v4l-utils (1.12.3 -> 1.12.5)
virtualbox
yast2 (3.2.40 -> 3.3.0)
yast2-ftp-server (3.2.1 -> 3.3.0)
yast2-network (3.2.28 -> 3.3.1)
yast2-ruby-bindings (3.2.13 -> 3.2.14)

=== Details ===

==== NetworkManager ====
Version update (1.8.0 -> 1.8.2)
Subpackages: NetworkManager-devel libnm-glib-vpn1 libnm-glib4 libnm-util2
libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0
typelib-1_0-NetworkManager-1_0

- Update to version 1.8.2:
+ Fix bug blocking startup wrongly waiting for carrier.
+ Fix handling of non UTF-8 strings in libnm and fix non NUL
terminated string.
+ Handle DNS priority for systemd-resolved DNS plugin.
+ Fix assuming master devices as they wait for slaves to
activate.
+ Fix reading managed state from device state file.
+ Fix crash activating bluetooth or WWAN connection.
+ No longer add a direct route to the DHCP server.
+ Several bug fixes and improvements.

==== akregator ====
Subpackages: akregator-lang

- Add fix-crash-if-no-current-frame.patch to fix another possible
crash (kde#381241)
- Add fix-crash.patch to fix a possible crash on start (kde#381416)

==== apr ====

- Rename package

==== autogen ====
Subpackages: libopts-devel libopts25

- Add patch to build with guile 2.2:
* autogen-guile-2.2.patch

==== babl ====
Version update (0.1.26 -> 0.1.28)

- Update to version 0.1.28:
+ Fast paths for Lav <-> Lch, release triggered by pending GIMP
release.

==== bash-completion ====
Version update (2.5 -> 2.7)

- Update to version 2.7
* Makefile: update default compatdir (#132)
* Make user completion file configurable, disable in tests
* test suite: Generalize xspec completion install check
* pyflakes: Remove redundant xspec completion
* test suite: Fix __expand_tilde_by_ref test expectation output
* pdfunite: New *.pdf completion
+ bash-completion (2.6)
* Add missing sidedoor to .gitignore (#114)
* test suite: Mark expected centos6 CI _filedir failures as such
* Expose version in BASH_COMPLETION_VERSINFO, use it in profile.d
script
* test suite: Skip an expected make test case failure in centos6 CI
* test suite: Fix ifdown and ifup CI test skipping
* test suite: Ignore env var pulled in by use of scp in tests
* test suite: If colon trim doesn't do anything, trim as usual
* tar: Comment spelling fixes
* test suite: Mark dpkg -L test case untested if no packages
installed
* test suite: Cosmetic tweaks
* dpkg: Fix dpkg -i home dir completion
* test suite: Improve ls home dir test descriptions
* python: Split module completion to separate helper
* micropython: New completion, aliased from python
* test suite: Add Python module completion test case
* python: Fix traceback avoidance on module completion error
* openssl: Parse available digests from dgst -h
* openssl: Add sha2 commands
* gm: New completion, commands only for now
* (test suite): Test screen -T completions
* (test suite): Set TERM to dumb, not dummy
* Revert "(test suite): Fix alias and cd cursor position tests"
* mplayer: Remove duplicate *.m4a and *.m4v associations
* mplayer, xine, etc: Associate *.mp4a and *.mp4v
* xine etc: Fix *.m4a association
* bind: Add option and argument (non-)completions
* _user_at_host: Set nospace only when completing username part
* _user_at_host: Append @ suffix to username part completions
* man: Don't check OSTYPE or GNU userland, just enable on all
systems
* (test suite): Set dcop result to untested if dcop server is not
running
* (test suite): Don't insist on loading all completions dynamically
* _configured_interfaces: Parse from /etc/network/interfaces.d/* on
Debian
* py.test: New completion
* oowriter: Associate with *.pdf
* Don't define BASH_COMPLETION_COMPAT_DIR
* ri: Add option and arg completions
* (test suite): Add our own dummy ri test fixture
* (test suite): Info test needs docs, don't exclude from CentOS
* (test suite): Fix CentOS 6 tcllib setup
* (test suite): Simplify renice test, fix with only one completion
* (test suite): Don't assume configured interfaces in CI setups
* Don't offer * as configured interface when there are none
* (test suite): Add basic CentOS 6 container for bash 4.1 coverage
* (test suite): Ignore runtime loaded env function changes
* (test suite): Add mailman bin dir to PATH for arch test
* arch: Parse options from --help
* (test suite): Load tested completions dynamically
* (test suite): Accept non-whitespace single word in
assert_complete_any
* (test suite): Avoid interference from user and system dirs (#87)
* (test suite): Install some things N/A in ubuntu14 to fedoradev
* (test suite): Add unrar to ubuntu14 container
* (test suite): Fix alias and cd cursor position tests
* (test suite): Add basic alpine test case
* alpine: Parse opts from -h output, add some opt arg completions
* (test suite): Install jshint globally in ubuntu14
* (test suite): Add mailman bin dir to PATH for some mailman tools
* (test suite): Install jshint to ubuntu14 container with npm
* unshunt: Parse options from --help
* (test suite): Test lsof on ubuntu14
* (test suite): Add basic hping3 test case
* (test suite): Add our ./configure to PATH to test it, test opts
* (test suite): Add bunch of packages to ubuntu14 container
* (test suite): Ensure /usr/(local/)games is in $PATH
* (test suite): Fix perl -d* test cases with no Devel::* installed
* (test suite): curl has lots of options, add more test prefix
* (test suite): Fix tar test case for ones having --owner-map
* (test suite): Unsupport various kill, renice cases if ps is N/A
* (test suite): Make chkconfig test behave better in container
* (test suite): Don't assume mounted filesystems in quota* tests
* newlist: Parse options from --help, add some arg non-completions
* (test suite): Delete trailing whitespace
* (test suite): Don't assume lists set up in newlist test cases
* (docker): Pull in missing fedoradev xvfb-run which dependency
* mr: Avoid stderr trash and test suite failure if man is N/A
* (test suite): Fix mmsitepass completion test
* tshark -G: Avoid stderr noise when running as superuser
* (docker): Run completion tests with xvfb-run, e.g. for gkrellm
* ssh-keygen: Make option parsing work with OpenSSH < 7
* synclient, udevadm: Avoid use of posix char classes for awk
* test suite: Add WIP Fedora dev config
* Travis: Switch tests to docker, update to Ubuntu 14
* xv: Associate with *.j2c, *.j2k, *.jp2, *.jpf, and *.jpg2 (Debian:
[#859774])
* eog: Associate with *.j2c and *.jpg2
* Bump copyright years
* xine etc: Associate uppercase *.WM[AV]
* mplayer: Associate *.weba (#112)
* xine etc: Associate *.webm and *.weba (#112)
- Modify patches
* FOO-dir-completion-boo905348.patch
* PS1-completion-boo903362.patch
* backtick-completion-boo940835.patch
* backticks-bsc963140.patch
* bash-completion-2.4.patch
* bash-completion.changes
* bash-completion.spec
* ls-completion-boo889319.patch
* respect-variables-boo940837.patch
* rm-completion-smart-boo958462.patch
* sh-script-completion-boo977336.patch

==== bluez ====
Subpackages: bluez-cups bluez-devel libbluetooth3

- enable sixaxis plugin
- Add %post/%postun to bluez-auto-enable-devices so the settings
change takes effect (boo#1039476)

==== ceph ====
Version update (12.1.0+git.1498654198.20d6a47cc9 ->
12.1.0+git.1499090920.2c11b88d14)
Subpackages: librados2 librbd1

- Update to version 12.1.0+git.1499090920.2c11b88d14:
+ With this update, Ceph no longer autocreates a pool called "rbd" with id 0
Deployment tools must take this into account!
+ systemd: Add explicit Before=ceph.target (bsc#1042973)

==== cmpi-provider-register ====

- Adapt sfcb_init_script to SLE12SP1 (bnc#1041885)

==== corosync ====

- some errors in spec file(bsc#1047862)
Modified:
corosync.spec
- improvement for corosync-keygen(bsc#1047861)
Added:
0007-improve-corosync-keygen.patch
- 1047860corosync report wrong version number(bsc#1047860)
Modified:
bnc#867767-add-version.patch

==== cyrus-imapd ====
Subpackages: cyradm perl-Cyrus-IMAP perl-Cyrus-SIEVE-managesieve

- Remove filler wording from description.
- Improve find commands.

==== dolphin ====
Subpackages: dolphin-part libdolphinvcs5

- Replace %lang_package with evaluated macro to be able to add proper
Provides/Obsoletes to avoid file conflicts during installation
- Rename -lang package to dolphin-part-lang and recommend it by the
dolphin-part package, the translations are used by the kpart too
* Avoid boo#1027925 in the context of boo#1047665

==== expat ====
Version update (2.2.0 -> 2.2.1)
Subpackages: libexpat-devel libexpat1 libexpat1-32bit

- Version update to 2.2.1 Sat June 17 2017
- Security fixes:
CVE-2017-9233 / bsc#1047236 -- External entity infinite loop DoS
Details: https://libexpat.github.io/doc/cve-2017-9233/
Commit c4bf96bb51dd2a1b0e185374362ee136fe2c9d7f
- [MOX-002] CVE-2016-9063 / bsc#1047240 -- Detect integer overflow;
(Fixed version of existing downstream patches!)
- (SF.net) #539 Fix regression from fix to CVE-2016-0718 cutting off
longer tag names;
[#25] More integer overflow detection (function poolGrow);
- [MOX-002] Detect overflow from len=INT_MAX call to XML_Parse;
- [MOX-005] #30 Use high quality entropy for hash initialization:
* arc4random_buf on BSD, systems with libbsd
(when configured with --with-libbsd), CloudABI
* RtlGenRandom on Windows XP / Server 2003 and later
* getrandom on Linux 3.17+
In a way, that's still part of CVE-2016-5300.
https://github.com/libexpat/libexpat/pull/30/commits
- [MOX-005] For the low quality entropy extraction fallback code,
the parser instance address can no longer leak,
- [MOX-003] Prevent use of uninitialised variable; commit
- [MOX-004] a4dc944f37b664a3ca7199c624a98ee37babdb4b
Add missing parameter validation to public API functions
and dedicated error code XML_ERROR_INVALID_ARGUMENT:
- [MOX-006] * NULL checks; commits
* Negative length (XML_Parse); commit
- [MOX-002] 70db8d2538a10f4c022655d6895e4c3e78692e7f
- [MOX-001] #35 Change hash algorithm to William Ahern's version of SipHash
to go further with fixing CVE-2012-0876.
https://github.com/libexpat/libexpat/pull/39/commits
- Bug fixes:
[#32] Fix sharing of hash salt across parsers;
relevant where XML_ExternalEntityParserCreate is called
prior to XML_Parse, in particular (e.g. FBReader)
[#28] xmlwf: Auto-disable use of memory-mapping (and parsing
as a single chunk) for files larger than ~1 GB (2^30 bytes)
rather than failing with error "out of memory"
[#3] Fix double free after malloc failure in DTD code; commit
7ae9c3d3af433cd4defe95234eae7dc8ed15637f
[#17] Fix memory leak on parser error for unbound XML attribute
prefix with new namespaces defined in the same tag;
found by Google's OSS-Fuzz; commits
xmlwf on Windows: Add missing calls to CloseHandle
- New features:
[#30] Introduced environment switch EXPAT_ENTROPY_DEBUG=1
for runtime debugging of entropy extraction
Bump version info from 7:2:6 to 7:3:6

==== flex ====
Version update (2.6.1 -> 2.6.4)

- Explicitly require m4 and library devel package
- Do not ship static library
- flex 2.6.4:
* Some minor performance enhancements
* honor user defined yy_* macros again
- includes changes from 2.6.3:
* several bug fixes resolved problems introduced in recent flex
versions regarding processing of comments, literals and various
quoting scenarios.
* fix buffer overflow through long path (bsc#1026047)
- includes changes from 2.6.2:
* a segfalt involving yyrestart(NULL) has been fixed
* flex should now handle quoting when mixed with m4 processing
correctly
* flex handles `[[' and `]]' correctly
* flex no longer generates non-ANSI code
* more compilation warnings were squashed in generated scanners
* prevented a buffer overflow that could occur when input buffers
were the exact wrong size
- drop flex-2.6.1-fPIC.patch
- build the shared library and split libfl

==== fontconfig ====
Subpackages: fontconfig-32bit fontconfig-devel

- Remove --with-pic which is only useful for static libs.

==== gconf2-branding-openSUSE ====
Version update (42.1 -> 42.3)

- do not build novell-sound-theme in the gconf2-branding-SLED build
to prevent duplicated binaries in openSUSE Leap. The
novell-sound-theme is taken from gconf2-branding-SLES sources on
both the SLED product and the SLES WE module. bsc#1046099
- bump versions

==== glabels ====
Subpackages: glabels-lang

- Drop conditional barcode BuildRequires, barcode-devel have made a
comeback.

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- add grub2-fix-build-with-flex-2.6.4.patch - fix build with flex 2.6.4+
that removed explicit (void) cast from fprintf call in yy_fatal_error.

==== hwdata ====
Version update (0.301 -> 0.302)

- Update to version 0.302

==== iio-sensor-proxy ====
Version update (2.1 -> 2.2)

- Update to version 2.2:
+ Fixes iio-sensor-proxy not receiving udev events because of
the excessive lockdown added in version 2.1.
+ Fixes a possible crash on startup due to a race condition.

==== kdeconnect-kde ====

- Add patch to fix unauthenticated HTML injection (kde#382243):
* 0001-Treat-device-names-as-plaintext-not-rich-text.patch

==== kio-extras5 ====

- Fix obsoletes
- Fix grammar errors in description.

==== kmod ====
Version update (23 -> 24)
Subpackages: kmod-compat libkmod2

- Update to new upstream release 24
* libkmod: fix use of strcpy
* depmod: fix string overflow
* depmod: ignore related modules in depmod_report_cycles
* libkmod: Fix handling of quotes in kernel command line
* libkmod-config: replace 0/1 with bool
* depmod: handle nested loops
- Drop 0001-use-correct-sort-method-in-test-array.patch,
0002-depmod-ignore-related-modules-in-depmod_report_cycle.patch,
0009-libkmod-Implement-filtering-of-unsupported-modules-o.patch
(applied upstream)
- Remove support for openSUSE < 13.2 (non-dracut mkinitrd)
- Separate bash completion functions into extra package
- Move some of the symlinks from kmod-compat to kmod,
as kmod still does not have native support for all functions.

==== konqueror ====
Subpackages: konqueror-devel konqueror-lang

- Recommend dolphin-part to make file management work out of the
box (boo#1047665)

==== konsole ====
Subpackages: konsole-part

- Rename -lang package to konsole-part-lang and recommend it by the
konsole-part package, the translations are used by the kpart too
(boo#1027925)

==== kwin5 ====
Version update (5.10.3 -> 5.10.3.1)
Subpackages: kwin5-devel

- Readd patch to revert upstream commit, the upstream "fix" is
not enough:
* 0001-Revert-Make-WindowSwitching-Alt-Tab-the-default-left.patch
- Update to 5.10.3.1
* Fix freeze in KWin::checkGLError on startup which affects
machines with an NVidia card (kde#381870)

==== latex2html ====
Version update (2016 -> 2017.2)

- Fix descriptions.
- Version update to latest release 2017.2:
* Various small fixes
- Sort out with spec-cleaner
- Remove post/postun phases expecting suseconfig to be around

==== libdiscid ====
Version update (0.6.1 -> 0.6.2)

- Update to 0.6.2:
* ISRC and MCN support on BSD
* LIB-60: fix make check for default device on generic/unknown platform
* make Doxygen output reproducible (no timestamps)
* remove newline for Linux device "1" from proc
- Refresh patch libdiscid-no-crypto.patch

==== libfabric ====

- Enable build on all archs
- Enable mlx build
- Add x86 build without libpsm2

==== libkexiv2 ====
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- Readd patch fix-reduce-required-exiv2-to-0.23.diff which is still
needed in SLE-12-SP3

==== libmcrypt ====

- Lie to autoconf and say we do not support readdir_r,
many applications incorrectly calculate the size of
struct dirent **result , this is one of those. Just use readdir
instead, which is thread-safe on glibc.

==== libpsm2 ====
Subpackages: libpsm2-2 libpsm2-compat

- Add libpsm2-compat-dependency-to-libpsm2.patch so libpsm_infinipath.so
provided by libpsm2-compat is linked to libpsm2 which provides
its missing symbols
- Remove obsolete psm2 library directory
- BuildRequire pkgconfig(udev) instead of udev: allow OBS to choose
udev-mini over udev, which in turn allows to break build cycles.
- Install psm2-compat library in the standard path
- Have libpsm2-compat conflict with libpsm_infinipath1

==== libquicktime ====

- adjust libquicktime-1.2.4-integer_overflow.patch to prevent
endless loop when there are less than 256 bytes to read
[bsc#1022805] CVE-2016-2399

==== libvirt ====
Version update (3.4.0 -> 3.5.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical
libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd
libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml
libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu
libvirt-daemon-xen libvirt-libs

- Update to libvirt 3.5.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
5004f121-virFdStreamThread-dont-exceed-length.patch,
1a4b21f1-set-EOF-on-end-of-stream.patch
- Remove --with-pic which is only for static libs
- Use %_smp_mflags instead of just %jobs

==== llvm3_8 ====
Subpackages: clang3_8-checker libLLVM3_8 libclang3_8

- Include provides and conflics in baselibs.conf for llvm3_8-devel,
clang3_8-devel, llvm3_8-LTO-devel, and llvm3_8-gold.
- Cleanup _constraints

==== logrotate ====
Version update (3.11.0 -> 3.12.3)

- Version update to 3.12.3:
* Fixed accident removal of rotated files with dateext. (#118)
* Line comments inside globs in config files are now skipped. (#109)
* logrotate now recovers from a corrupted state file. (#45)
* createolddir now creates old directory as unprivileged user. (#114)
* weekly rotations are now predictable and configurable. (#93)
* Errors in config files are no longer treated as fatal errors. (#81)
* configure --with-default-mail-command specifies default mail command. (#100)
* Fixed heap buffer overflow when parsing crafted config file. (#33)
* build fixes related to -Werror (#119) and -Werror=format= (#108)
* configure --enable-werror now controls use of the -Werror flag (#123)
* copy and copytruncate directives now work together again
* unlink() is no longer preceded by open() unless shred is enabled (#124)
* compress and uncompress now take commands from $PATH, too (#122)
- By default disable werror while building
- Remove aaa_base compat setting that is from 2003, we do not
support such migration anymore

==== marble ====
Subpackages: libastro1 libmarblewidget-qt5-27 marble-devel

- Drop Fix-utm-enum-value.patch
- Add Add-fallback-InputHandler.patch from upstream instead to fix
the crash (boo#1044747, kde#381872)
- Add Fix-utm-enum-value.patch and reverse-apply it, this upstream
commit causes a crash when adding bookmarks if switched to UTM
view angles because the necessary handler functions for the
dialog are not implemented yet (boo#1044747, kde#381872)
- Add Fix-plain-map-and-political-map-showing-no-content.patch to
fix the plain map and the political map being not displayed at
all (kde#379297)

==== mercurial ====
Version update (4.2 -> 4.2.2)
Subpackages: mercurial-lang

- Mercurial 4.2.2
This is a regularly-scheduled bugfix release.
* largefiles: avoid a crash when archiving a subrepo with largefiles disabled
* rebase: also test abort from pretxnclose error
* rebase: backed out changes 2519994d25ca and cf8ad0e6c0e4 (issue5610)
* rebase: reinforce testing around precommit hook interrupting a rebase
- Mercurial 4.2.1
This is a regularly-scheduled bugfix release.
* `hg graft` now works when grafting across merges that were problematic
before (b4e1e30528c7).
* A race condition in `hg status` was partially fixed (issue5584).
* The message about deprecated SHA-1 hashes in the [hostfingerprints] config
section now references the correct syntax for replacing them with SHA-256
hashes (issue5559).

==== obs-service-set_version ====

- try to avoid python-packaging to support non-SUSE distros

==== okteta ====
Subpackages: okteta-devel okteta-lang

- Improve description text (boo#1047988)

==== opencv ====
Subpackages: libopencv3_2 opencv-devel

- Add conditional for the qt5/qt4 integration
* This is used only for gui tools, library is not affected
- Add provides/obsoletes for the qt5 packages to allow migration
- Drop patch opencv-qt5-sobump.diff
* Used only by the obsoleted qt5 variant
- Cleanup a bit with spec-cleaner
- Use %cmake macros
- Remove the conditions that are not really needed
- Add tests conditional disabled by default
* Many tests fail and there are missing testdata
- Switch to pkgconfig style dependencies

==== openmpi ====
Subpackages: openmpi-config openmpi-devel openmpi-libs

- Add libfabric support on x86
- Move openmpi-totlview.tcl to openmpi-config package for compat with openmpi2
- Build with openucx support on 64b platforms

==== openssl-1_0_0 ====
Subpackages: libopenssl-1_0_0-devel libopenssl1_0_0 libopenssl1_0_0-32bit

- The description is supposed to describe the package, not the
development process or history.
- Ship the -cavs subpackage with the FIPS testing helper binaries

==== patterns-devel-C-C++ ====

- Remove ddd as it didn't have release in last 10 years and thus
we should not really promote it

==== plasma5-workspace ====
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Add logoutdialog-honor-Offer-shutdown-options.patch to make the
logout dialog respect the "Offer shutdown options" setting and
hide "Reboot" and "Shutdown" if disabled (boo#1008844)

==== procps ====
Subpackages: libprocps6

- Add patch procps-ng-3.3.12-sysctl-iobuf.patch to increase I/O
buffer for reading and writing values below /proc/sys (bsc#1039941)
- Add patch procps-ng-3.3.12-stable_secret.patch to avoid messages
on unset /proc/sys/net/ipv6/conf/*/stable_secret due EIO

==== psmisc ====

- Remove patches
* psmisc-22.21-lessnfs.patch
* psmisc-22.21-mntpt.patch
* psmisc-23.0-net.patch
- Add patch
0001-Use-mountinfo-to-be-able-to-use-the-mount-identity.patch
from https://gitlab.com/bitstreamout/psmisc/tree/mountinfo
which is a heavily rework fuser used on NFS
* Use mountinfo to be able to use the mount identity
which allows to distinguish different mounts with the
same device number as it happens with NFS shares.
* Smaller cleanup as support of chroot environments
and older systems.
* Add support for name_to_handle_at() system call to
get the real mount ID for each file
- Use test suite of psmisc in %check rpm section

==== python-certifi ====
Subpackages: python2-certifi python3-certifi

- Fix wrong-script-interpreter rpmlint error.
- Fix script-without-shebang rpmlint warning.

==== python-pywbem ====

- Remove redundant cleaning actions.

==== python-rpm-macros ====
Version update (2017.06.21.6641889 -> 2017.06.29.107ac7a)

- version bump to 2017.06.29.107ac7a
- fix skip_python2 in environment where python2 is not actually present

==== qhull ====
Version update (2012.1.2 -> 2015.2)
Subpackages: qhull-devel

- updated to 2015.2 (7.2.0):
* A large number of changes, please see:

https://github.com/qhull/qhull/blob/5a79a0009454c86e9848646b3c296009125231bf/src/Changes.txt
- Update to more recent macros
- General spec-file cleanups

==== rdma-core ====
Subpackages: libibcm1 libibumad3 libibverbs libibverbs1 libmlx5-1 librdmacm1
rdma-core-devel rsocket

- BuildRequire pkgconfig(libudev) instead of libudev-devel: this
allows OBS to chose libudev-devel-mini and produce a better
rebuild-chain (and break cycles).

==== screen ====
Version update (4.5.1 -> 4.6.1)

- adding %set_permissions and %verify_permissions macros
for /run/uscreens/
- adding %tmpfiles_create macro for /usr/lib/tmpfiles.d/screen.conf
- spec file: adding PreReq for permissions
- GNU Screen 4.6.1: bugfix release
* problems with starting session in some cases
* parallel make install
* segfault when querying info on nonUTF locale
- GNU Screen 4.6.0:
* Update Unicode wide tables to 9.0
* Support more serial speeds
* Improved namespaces support
* Migrate from fifos to sockets
* Start viewing scrollback at first line of output
- drop upstreamed 0001-Follow-up-to-bc5ea98-fix-texinfo-syntax-errors.patch

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Replace patch with version merged upstream, to avoid potentially
killing the X server:
* 0001-Also-theme-the-default-cursor-for-the-root-window.patch
- Add patch to keep old entries in XAUTHORITY file (boo#1043221):
* 0001-Do-not-truncate-XAUTHORITY-file-on-login.patch

==== shared-mime-info ====

- Replace %mime_database_post/postun with respective file triggers
in shared-mime-info: any file put into /usr/share/mime will
trigger the execution of the script. In order to not break the
macros short-term they are being redefined to %nil.
- Drop redundant %clean section.

==== subversion ====
Version update (1.9.5 -> 1.9.6)
Subpackages: libsvn_auth_gnome_keyring-1-0 libsvn_auth_kwallet-1-0
subversion-bash-completion subversion-devel subversion-perl subversion-python
subversion-server subversion-tools

- Apache Subversion 1.9.6 (bsc#1026936):
This change makes Subversion resilient to collision attacks,
including SHA-1 collision attacks such as <http://shattered.io/>.
https://subversion.apache.org/faq#shattered-sha1
* fsfs: never attempt to share directory representations
* fsfs: make consistency independent of hash algorithms
* cp/mv: improve error message when target is an unversioned dir
* merge: reduce memory usage with large amounts of mergeinfo
* 'svnadmin freeze': document the purpose more clearly
* dump: fix segfault when a revision has no revprops
* fsfs: improve error message upon failure to open rep-cache
* work around an APR bug related to file truncation
* javahl: follow redirects when opening a connection

==== unzip ====
Subpackages: unzip-doc

- Updated Fix-CVE-2014-8139-unzip.patch: the original patch was
causing errors testing valid jar files:
$ unzip -t foo.jar
Archive: foo.jar
testing: META-INF/ bad extra-field entry:
EF block length (0 bytes) invalid (< 4)
testing: META-INF/MANIFEST.MF OK
testing: foo OK
(see https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-8139
where the updated patch was taken from)

==== v4l-utils ====
Version update (1.12.3 -> 1.12.5)
Subpackages: libv4l libv4l-devel libv4l1-0 libv4l1-0-32bit libv4l2-0
libv4l2-0-32bit libv4l2rds0 libv4lconvert0 libv4lconvert0-32bit

- Update to version 1.12.5:
* dvb-scan: fix the logic for multi-section handling
From version 1.12.4:
* libdvbv5: T2 delivery descriptor: fix wrong size of bandwidth
field
* desc_t2_delivery: consider valid to have a short T2 descriptor
* desc_t2_delivery: properly handle cell and subcell tables
* desc_t2_delivery: improve print dumps of T2 delivery
* desc_t2_delivery: resize frequency array for subcel freqs
* libdvbv5: add support for more PMT descriptors
* libdvbv5: fix T2 delivery descriptor parsing in
dvb_desc_t2_delivery_init()

==== virtualbox ====
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- Fix several problems with the startup scripts. The SysV form is no longer
used for most packages as proper systemd
service files have been created. These fixes address bsc#1037291, #1043532,
and #1045871.
- Increase reserved disk space from 4 to 5 GB. This change was suddested as a
fix for the 32-bit failures.

==== yast2 ====
Version update (3.2.40 -> 3.3.0)

- Fix omitting button in CWM::Dialog and make API consistent with
CWM.show (boo#1039901)
- 3.3.0

==== yast2-ftp-server ====
Version update (3.2.1 -> 3.3.0)

- Added missing StartDaemon flag to internal data structure in
order to read it from the AY configuration file. (bnc#1047232)
- 3.3.0

==== yast2-network ====
Version update (3.2.28 -> 3.3.1)

- Display a warning in AutoYaST installation when importing the DNS
configuration with disabled seconds stage (the second stage is
currently required for writing the config) (bsc#1046198)
- 3.3.1
- bnc#1046735
- do not update sysconfig when no IP is given in case of static
NIC configuration.
- bsc#1044982
- handle bad pci class/subclass ids used by Mellanox ConnectX-3
- nmoreychaisemartin@xxxxxxxx
- 3.3.0
- bnc#1046677
- disable widgets which cannot be configured by the selected
network service
- 3.2.29

==== yast2-ruby-bindings ====
Version update (3.2.13 -> 3.2.14)

- Set proper title also for YaST2 System Log (bsc#1046153)
- 3.2.14


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups