Mailinglist Archive: opensuse-factory (1134 mails)

< Previous Next >
Re: [opensuse-factory] nothing provides libxine1-devel
  • From: Luiz Fernando Ranghetti <elchevive68@xxxxxxxxx>
  • Date: Sun, 17 Jun 2012 10:50:03 -0300
  • Message-id: <CADPAnrzPzR47=c60YP127CDgYic66jAkUoB171p7aqdSucu17A@mail.gmail.com>
2012/6/17 Carlos E. R. <robin.listas@xxxxxxxxxxxxxx>:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 2012-06-17 14:23, Dominique Leuenberger wrote:
On Sun, 2012-06-17 at 14:19 +0200, Dominique Leuenberger wrote:
On Sun, 2012-06-17 at 16:14 +0400, Ilya Chernykh wrote:
What is the replacement?

Use BuildRequires: pkgconfig(libxine) and you don't ever have to
worry how the maintainer renames his rpm packages.

saves you a lot of trouble.

Alternatively, the correct name would be libxine-devel.

libxine1 is the shared library name as per SLPP.. no reason to rename
the devel package when there is an ABI bump (I guess at one point the
maintainer of xine-lib saw that too and changed the name to
libxine-devel)

Actually, there is libxine1 and libxine2. As most users replace the
openSUSE version with the packman version, we should use the same naming
convention they use, or things may break.


Hi,

If I'm not wrong, the mantainer of openSUSE and Pacman version is the
same. He update the version of xine (another efect was the inclusion
of libavutil). In that thread is pointed to a bugzilla number:

https://bugzilla.novell.com/show_bug.cgi?id=762784

regards,

Luiz
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups