Mailinglist Archive: opensuse-factory (838 mails)

< Previous Next >
Re: [opensuse-factory] openSUSE won't upgrade successfully from 11.3 to 11.4


On 03/08/2011 11:14 AM, Stephan Kulow wrote:
Am Dienstag, 8. März 2011 schrieb Ralf Lang:
I just verified on two distinct installations that zypper dup from
11.3 to 11.4 will fail and break the package system by removing
liblzma. This might be a major pita when 11.4 is announced and the
average guy does an upgrade.

https://bugzilla.novell.com/show_bug.cgi?id=677678

OK, that bug should have a work around now. If someone could verify (anyone
still having 11.3? :) it would be fantastic.

The work around works for me.

After changing the repos
-> zypper in zypper
-> zypper up rpm
-> zypper dup

However, I do loose my display in this process (after zypper in zypper)
and end up having to reboot to get into runlevel 3. Then I needed to
configure the network manually as yast is not working yet and I had the
network setup to be dealt with by NetworkManager.

The work around allows me to complete the upgrade, however, it's still
not in an appropriate state for the "average joe".

BTW, this is the second machine that had the "loosing the X-server"
problem. Thus I'd say it is not isolated. I did not try the "just run
zypper dup" method.

After zypper dup is complete X-server works again as expected.

Later,
Robert

--
Robert Schweikert MAY THE SOURCE BE WITH YOU
Novell-IBM Software Integration Center LINUX
Tech Lead
rschweikert@xxxxxxxxxx
rschweikert@xxxxxxxxxx
781-464-8147

Novell
Making IT Work As One
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >