Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] unexpected / undocumented question during 11.1 -> 11.2 upgrade
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Thu, 12 Nov 2009 01:19:05 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0911120109120.5098@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Wednesday, 2009-11-11 at 09:04 +0100, Josef Reidinger wrote:

Carlos E. R. write:

Why would the upgrade of zypper have to do anything to kde3? It is a text
mode application.

Hi, it is quite simple. Answer is dependencies. After each update system still
must working.

System, yes... but not everything, a dup is something drastic.

You want update zypper -> require new libzypp -> I think that old yast
bindings doesn't work with old libzypp due to ABI changes -> update yast ->

But why update yast? It was not requested. Sure, yast will not work - so what? If the user wants to update yast, he will do a zypper dup yast as well.

new yast require new qt-bindings -> update qt -> and this leads to get remove
kde3, because you don't have qt3 after this step ( I think it is related also
to renaming of packages from name(name4 for kde4) to name3(name for kde4). so
it naturally update to kde4 version your kde3 packages.

Yes, obviously yast depends on libzypp, but not the other way round. I can understand that updating yast pulls all those deps, but as libzypp should not depend on yast, I still do not see why updating libzypp should pull yast.

Maybe I misunderstand the way a dependency works :-?

- -- Cheers,
Carlos E. R.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkr7VIIACgkQtTMYHG2NR9X7fQCaAquMd/VXtVaw7bBClfWkryL5
lS8An0rUP+Zg+I5N/1spoTtRYuBRZfmt
=au8i
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups