Mailinglist Archive: opensuse-factory (549 mails)

< Previous Next >
Re: [opensuse-factory] unexpected / undocumented question during 11.1 -> 11.2 upgrade
  • From: Dave Plater <davejplater@xxxxxxxxx>
  • Date: Wed, 11 Nov 2009 10:53:22 +0200
  • Message-id: <4afa7b85.1818d00a.0839.ffffdd75@xxxxxxxxxxxxx>
On 11/11/2009 10:04 AM, Josef Reidinger wrote:
Carlos E. R. write:

On Tuesday, 2009-11-10 at 10:50 +0200, Dave Plater wrote:

On 11/10/2009 12:11 AM, Greg Freemyer wrote:


They should remind you that kde3 is no longer in the main repos and you
need :-

Why would the upgrade of zypper have to do anything to kde3? It is a text
mode application.


Hi, it is quite simple. Answer is dependencies. After each update system
still
must working.
You want update zypper -> require new libzypp -> I think that old yast
bindings doesn't work with old libzypp due to ABI changes -> update yast ->
new yast require new qt-bindings -> update qt -> and this leads to get remove
kde3, because you don't have qt3 after this step ( I think it is related also
to renaming of packages from name(name4 for kde4) to name3(name for kde4). so
it naturally update to kde4 version your kde3 packages.


I know it's not quite zypper dup but when I tried an update from 11.2
rc2 x86_64 dvd from rc1, I couldn't add any of my existing repos
(http://bugzilla.novell.com/show_bug.cgi?id=552439) and it wanted to
remove most of my kde3 installation. Qt3 is still in 11.2 so it couldn't
have been due to that so I assumed that it was because kde3 was no
longer in 11.2 repo and thus an unsupported package. From experience
when I have done a zypper dup and have disabled most of my extra
repositories, I have had to renable them to prevent packages from being
removed.
Regards
Dave P
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >