Mailinglist Archive: opensuse-buildservice (119 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS 2.7.0 RC 1
On Freitag, 13. Mai 2016, 11:43:39 wrote Carsten Höger:

On 13.05.2016, at 11:26 , Adrian Schröter <adrian@xxxxxxx> wrote:
Didn’t you write that "LDAP support works again” ?

I admit, that I haven't tried the combination with anonymous disabled.
It was complete broken in 2.7 before RC1...

It worked before the update to 2.7 at least.

I will try to bring the fallback behaviour back ...

Even with anonymous on, I cannot login in ldap mode.
Neither with the local Admin user nor with the existing ldap accounts.

Yes, the general fallback is not working atm. Please try the patch
I sent you in my other mail.

I assume these changes here
have still to be applied to user login usernames with dots?

This is the trace of a login attempt of an ldap user:

[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.48] Started POST
"/user/do_login" for at 2016-05-13 11:42:07 +0000
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.48] Processing by
Webui::UserController#do_login as HTML
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.48] Parameters:
"username"=>"carsten.hoeger", "password"=>"[FILTERED]", "commit"=>"Log In"}
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.62] Completed 500 Internal
Server Error in 139ms (ActiveRecord: 2.8ms | Backend: 0.0ms | XML: 0.0ms)
[7e8bd604-d0d0-4cec-abf6-cab400d2b83f] [1683:355.63]
NoMethodError (undefined method `kind' for #<Project:0x00000005c5d410>):

This looks more like a complete different problem. Your database has no "kind"
in project table? That can't work since quite some time ...


Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups