Mailinglist Archive: opensuse-buildservice (151 mails)

< Previous Next >
[opensuse-buildservice] Build time dependency resolution (multiple version support)
Hi,

I'm currently running into the issue described here:

http://lists.opensuse.org/opensuse-buildservice/2014-01/msg00156.html

The following statements seem to be to be true:

1) In a given distribution, only the most recently built version of a
package will be available to satisfy BuildRequires

2) If a mis-matched version of a BuildRequires dependency exists in a
distribution in a package's project, no other project's distributions
will be searched for that dependency, even if the BuildRequires
specifies a version available in a different distribution that is in
the repository search configuration

Can someone please confirm they are correct?

If they are correct, are there any plans to support multiple versions
of builds for satisfying BuildRequires? I started to look at the code
around this and it seems pretty dense - what direction would you point
someone in if they wanted to modify this behavior? The only other
options I can think of are all very cumbersome in terms of
administrative overhead within OBS.

Thanks for your help.
Andy
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups