Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
[opensuse-buildservice] Build time resolver fails after newer package version was added to repo
Hi,

on my private instance, I created a project to host 3rd-party binary
rpms to build against.
One of my packages has a 'Build-Requires: foo = 4.1' and could be
properly built.
After I added package foo-5.0 to the 3rd-party-hosting project, my
packages is unresolvable now: 'nothing provides foo = 4.1'
Does the resolver only take the newest version into account by design or
is this a problem with the foo rpm?

The output of dumpsolv :full.solv shows that both the 4.1 and 5.0
version of foo are there.

OBS version is 2.4.5-6.1

Any help much appreciated,
Martin

--
| Martin Weber
| RazorCat Development GmbH
| Witzlebenplatz 4 fon: +49-(30)-536 357 46
| 14057 Berlin fax: +49-(30)-536 357 60
|
|--------------------------------------------
| Geschäftsführer: Michael Wittner
| Sitz der Gesellschaft: Berlin
| Amtsgericht: Berlin, HRB 65326
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups