Mailinglist Archive: opensuse-buildservice (253 mails)

< Previous Next >
Re: [opensuse-buildservice] Other Platforms than (open)SUSE in BS
  • From: Matthias Hopf <mhopf@xxxxxxx>
  • Date: Wed, 22 Nov 2006 17:36:27 +0100
  • Message-id: <20061122163627.GA14477@xxxxxxx>
On Nov 17, 06 20:50:02 +0530, Jigish Gohil wrote:
> On 11/17/06, Michael Schroeder <mls@xxxxxxx> wrote:
>
> >
> >This makes it hard for people that import your package and use
> >different repository names. I think it's better to use
> >
> >%if 0%{?suse_version} >= 1010
> >BuildRequires: xorg-x11-compat70-devel
> >%endif
> >%if 0%{?suse_version} != 1000
> >BuildRequires: libdrm-devel
> >%endif
> >
>
> Yeah that was a special case, as XOrg7_SUSE_Linux_10.1 doesn't require
> xorg-x11-compat70-devel too and caused a clash in BS.

Also, it would have to be %if 0%{?suse_version} <= 1010 ...

> The above way is proper.

Also remember that it's only about SUSE, so supporting other
distributions adds additional work.

Matthias

--
Matthias Hopf <mhopf@xxxxxxx> __ __ __
Maxfeldstr. 5 / 90409 Nuernberg (_ | | (_ |__ mat@xxxxxxxxx
Phone +49-911-74053-715 __) |_| __) |__ labs www.mshopf.de
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >