Mailinglist Archive: opensuse-bugs (4251 mails)

< Previous Next >
[Bug 966671] No application can be run after some uptime (No protocol specified)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 17 May 2017 13:59:04 +0000
  • Message-id: <bug-966671-21960-KXoytbyufn@http.bugzilla.novell.com/>
http://bugzilla.novell.com/show_bug.cgi?id=966671
http://bugzilla.novell.com/show_bug.cgi?id=966671#c10

Michael Matz <matz@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |matz@xxxxxxxx

--- Comment #10 from Michael Matz <matz@xxxxxxxx> ---
(I was just triggered to look into this a bit by an IRC conversation,
this is what I found out, perhaps it helps somebody to investigate further
and fix it)

Is the tmpfile cleaner perhaps regularly removing /tmp/xauth* ?
kdeinit[45] sometimes seems to store the xauth tokens into
/tmp/xauth-$uid-_$distplaynum, instead of using ~/.Xauthority (though only for
the benefit for using kdesu/su/sudo). It does so only when $XAUTHORITY isn't
set
before. And for some processes it instead uses
/tmp/kde-$username/xauth-$uid-_$displaynum (I don't know based on which
decisions).

I guess if the tmpfiles cleaner comes and removes those files some things
breaks. On my tumbleweed system I seem to have the tmpfile cleaner configured
in a way that those aren't cleaned up, so I don't have this problem, but
perhaps
you have like mkubecek as well?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >