Mailinglist Archive: opensuse-bugs (4248 mails)

< Previous Next >
[Bug 1021246] New: Postgresql94 POSTGIS 2.3.1 error: undefined symbol: GEOSVoronoiDiagram
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 21 Jan 2017 07:57:20 +0000
  • Message-id: <bug-1021246-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1021246


Bug ID: 1021246
Summary: Postgresql94 POSTGIS 2.3.1 error: undefined symbol:
GEOSVoronoiDiagram
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Installation
Assignee: yast2-maintainers@xxxxxxx
Reporter: spocht@xxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

Hello,

I get an error when creating the postgis extension:

ERROR: could not load library "/usr/lib/postgresql94/lib64/postgis-2.3.so":
/usr/lib/postgresql94/lib64/postgis-2.3.so: undefined symbol:
GEOSVoronoiDiagram

An ldd on postgis-2.3.so gives:

linux-vdso.so.1 (0x00007ffc8612f000)
libgeos_c.so.1 => /usr/lib64/libgeos_c.so.1 (0x00007f8aa0bb8000)
libproj.so.12 => /usr/lib64/libproj.so.12 (0x00007f8aa094d000)
libjson-c.so.2 => /usr/lib64/libjson-c.so.2 (0x00007f8aa0741000)
libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f8aa03d6000)
libm.so.6 => /lib64/libm.so.6 (0x00007f8aa00d9000)
libSFCGAL.so.1 => /usr/lib64/libSFCGAL.so.1 (0x00007f8a9f2db000)
libc.so.6 => /lib64/libc.so.6 (0x00007f8a9ef38000)
libgeos-3.4.2.so => /usr/lib64/libgeos-3.4.2.so (0x00007f8a9eb95000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f8a9e80c000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f8a9e5f5000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f8a9e3d8000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f8a9e1d3000)
libz.so.1 => /lib64/libz.so.1 (0x00007f8a9dfbd000)
liblzma.so.5 => /usr/lib64/liblzma.so.5 (0x00007f8a9dd94000)
libCGAL.so.10 => /usr/lib64/libCGAL.so.10 (0x00007f8a9db6a000)
libCGAL_Core.so.10 => /usr/lib64/libCGAL_Core.so.10 (0x00007f8a9d931000)
libmpfr.so.4 => /usr/lib64/libmpfr.so.4 (0x00007f8a9d6d6000)
libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007f8a9d44e000)
libboost_thread.so.1.54.0 => /usr/lib64/libboost_thread.so.1.54.0
(0x00007f8a9d236000)
libboost_system.so.1.54.0 => /usr/lib64/libboost_system.so.1.54.0
(0x00007f8a9d032000)
libboost_serialization.so.1.54.0 => /usr/lib64/libboost_serialization.so.1.54.0
(0x00007f8a9cdc4000)
/lib64/ld-linux-x86-64.so.2 (0x000055fb2fc8b000)
librt.so.1 => /lib64/librt.so.1 (0x00007f8a9cbbc000)


I realize that libgeos-3.4.2 is picked but in the docu it says that postgis
needs libgeos 3.5+. So I installed libgeos-3.5.1 but this is still not used by
postgis. And maybe this is not the root of the problem.

Would be great if someone could point me into the correct direction.

Thx.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >