i don't know if this is known, the update for rubygem-delayed_job from SLE 11 SDK Updates is kept back, because obs-api requires a version < 2.0.0 This persists since the ruby upgrades in the last weeks. Is the new version of rubygem-delayed_job really not compatible with obs-api?
host:/srv/obs/log # zypper in rubygem-delayed_job-3.0.3-0.7.3.2.x86_64 Loading repository data... Reading installed packages... Resolving package dependencies...
Problem: obs-api-2.3.8-3.1.x86_64 requires rubygem-delayed_job < 2.0.0, but this requirement cannot be provided deleted providers: rubygem-delayed_job-1.8.4-3.3.x86_64 uninstallable providers: rubygem-delayed_job-1.8.4-0.1.38.x86_64[SLE11-SDK-SP2] rubygem-delayed_job-1.8.4-3.2.i586[openSUSE:Tools:2.3] rubygem-delayed_job-1.8.4-3.2.x86_64[openSUSE:Tools:2.3] Solution 1: Following actions will be done: downgrade of obs-api-2.3.8-3.1.x86_64 to obs-api-1.7.7-0.3.1.x86_64 install obs-api-1.7.7-0.3.1.x86_64 (with vendor change) obs://build.opensuse.org/openSUSE:Tools --> SUSE LINUX Products GmbH, Nuernberg, Germany Solution 2: do not install rubygem-delayed_job-3.0.3-0.7.3.2.x86_64 Solution 3: break obs-api-2.3.8-3.1.x86_64 by ignoring some of its dependencies
Choose from above solutions by number or cancel [1/2/3/c] (c): c host:/srv/obs/log # rpm -q obs-api --requires|grep delayed_job rubygem-delayed_job < 2.0.0