Mailinglist Archive: opensuse (621 mails)

< Previous Next >
[opensuse] glibc version
  • From: Roger Oberholtzer <roger.oberholtzer@xxxxxxxxx>
  • Date: Mon, 10 Jun 2019 10:55:52 +0200
  • Message-id: <CANkOqwPhGSX+n6j3owYzA6n28aQt7c+o36=YAVLBBEM-S+dUxA@mail.gmail.com>
I have an openSUSE 42.3 system on which I am trying to run some
libraries compiled for Ubuntu. They are for Z+F lasers
(https://www.zf-laser.com/Home.91.0.html?&L=1), not that this is
important. But they are starting to add Linux support for their
devices.

Generally, lots of things work. The only issue is that some of the
libraries want a newer version of glibc. openSUSE 42.3 uses 2.22, and
these libraries want 2.27.

I know that glibc supports various versions at the same time. I guess
it is part of the install. That is, IIUC, version 2.22 supports that
release, as well as some earlier versions. One does not have different
versions of the RPM installed.

I think I know the answer to this, but is it possible to update glibc
to version 2.27 on openSUSE 42.3? I'm okay if it is in some parallel
directory that only these libraries/binaries know about. Has anyone
done this kind of thing?

--
Roger Oberholtzer

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >