Mailinglist Archive: opensuse (958 mails)

< Previous Next >
Re: [opensuse] Where to set the domain name? - Leap 15.1 beta
On 07/05/2019 08.31, Per Jessen wrote:
Carlos E. R. wrote:

On 06/05/2019 22.55, Per Jessen wrote:
Carlos E. R. wrote:

On 06/05/2019 21.14, Andrei Borzenkov wrote:
06.05.2019 21:59, Carlos E. R. пишет:


On another machine I have my own script hanging from NM that edits
/etc/hosts dynamically to write the correct full name and current
IP.> But there must be a better way.

If you are going to say that it is the job of the DHCP server,

All that I'm trying to say is that you are barking up the wrong
tree. If your concern is (non) working "hostname -f" or how to
associate dynamic IP with static label it is not related to "Domain
Name" field in YaST.

I'm not barking. I'm asking what is the correct place to set the
domain name in Leap. It is very simple!

You are basically saying "nowhere".

I think Andrei is saying it isn't necessary and asks you to show
which problem it creates for you.

In this machine, which is only a test machine, that "domainname" does
not work. That is, if you wish, an aesthetic problem.

If I read the man page correctly, "domainname" will print the NIS
domain? Did you mean to write "hostname -f" ?

NIS domain? I missed that, sorry (the command has the wrong name, IMHO).
Yes, I mean "hostname -f".


But on other machines, postfix does not start if the host and domain
names do not work.

Well, here we should probably restrict ourselves to what happens on
Leap15.1. postfix is no doubt running fine, it is started by default.

Maybe, but I'm not testing it now. It is quite complicated to do, I'm
examining previous steps that I would need to set it up. Setting the
domain name is one step, I found a hurdle, and asked. Simple! I don't
understand the brouhaha and some people getting angry, as if hitting a
bees nest :-(


So, as there is no way in YaST to set the domain name we are left to
our own.

I still don't see any description of the actual problem you are seeing.
Preferably with error messages etc.

First post in the thread:


+++............
Hi,

Elesar:~ # hostname -f
hostname: Name or service not known
Elesar:~ # hostname -d
hostname: Name or service not known
Elesar:~ # hostname -y

Elesar:~ # hostname -A

Elesar:~ # hostname
Elesar
Elesar:~ #


So, I start and look into Network Settings, and in hostname I try to
write a domain name after a dot - it does not allow me to set a domain name.

Where is one supposed to write the domain name?
............++-

I think it is pretty simple! :-)


Maybe the answer is "you can not set the domain name of the machine. You
have to set it up in the DNS. The query about your own IP answers the
fqdn". But that answer does not consider multiple domains, so... :-?

That would leave me very confused.


But then I would ask: "what was then the purpose of the missing domain
name entry box that previous yast versions had? If it was not to set the
domain name of the machine, then what was its purpose?" It has been
there for decades.

--
Cheers / Saludos,

Carlos E. R.

(from oS Leap 15.0 x86_64 (Minas Tirith))

< Previous Next >
This Thread