Mailinglist Archive: opensuse (958 mails)

< Previous Next >
Re: [opensuse] Where to set the domain name? - Leap 15.1 beta
On 06/05/2019 21.14, Andrei Borzenkov wrote:
06.05.2019 21:59, Carlos E. R. пишет:
On 06/05/2019 20.45, Andrei Borzenkov wrote:
06.05.2019 21:30, Carlos E. R. пишет:
On 06/05/2019 20.28, Andrei Borzenkov wrote:
06.05.2019 21:23, Carlos E. R. пишет:
On 06/05/2019 19.59, James Knott wrote:
On 05/06/2019 01:28 PM, Carlos E. R. wrote:
No, I don't. See photo.

It should be there.  I guess yours is defective.  Must be one of those
weird Spanish things.  ;-)



Are you using Leap 15.1 Beta?


On my laptop, which is using Leap 15.0, YaST has that domain box.

So, is this a bug in 15.1, or is it intentional?


Again - what exactly constitutes "bug"? What worked on 15.0 but does not
work on 15.1 because this field is not present?


The disappearance of the domain name box in yast, what else?


Removal of input field that apparently served little purpose is a bug?

News to me.


With that box missing, what is the correct manner of setting the domain
name, so that command "hostname -f" works?


This field had very little to do with "hostname -f". "hostname -f"
returns result of name resolution. So define your FQDN in /etc/hosts or
on your DNS server. That happened when "Assign hostname to loopback" was
checked - YaST added entry to /etc/hosts with FQDN (hostname.domain) so
"hostname -f" worked.

The IP is dynamic (not NM), so I can not add the line to /etc/hosts
myself (not talking of loopback).

Your requirement was that "hostname -f" works and checking "Assign
hostname to loopback" makes it work.

No, that way breaks postfix and dovecot. There is an old bugzilla about it.



Ie, if my current IP is 192.168.1.132, I should get:


192.168.1.132 Elesar.valinor

or

192.168.1.133 Elesar.valinor

the next day:

192.168.1.134 Elesar.valinor


So configure IP reservation on your DHCP server or use static address if
it matter to you.

Why should I? And what would I do when I tether to my android phone?




On another machine I have my own script hanging from NM that edits
/etc/hosts dynamically to write the correct full name and current IP.> But
there must be a better way.

If you are going to say that it is the job of the DHCP server,

All that I'm trying to say is that you are barking up the wrong tree. If
your concern is (non) working "hostname -f" or how to associate dynamic
IP with static label it is not related to "Domain Name" field in YaST.

I'm not barking. I'm asking what is the correct place to set the domain
name in Leap. It is very simple!

You are basically saying "nowhere".



I don't
agree. It can be an android phone, so not controllable.


How exactly changes in YaST suddenly become relevant to Android phones?

You are being intentionally obtuse.


--
Cheers / Saludos,

Carlos E. R.

(from openSUSE, Leap 15.1 x86_64 (ssd-test))

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread