Mailinglist Archive: opensuse (389 mails)

< Previous Next >
Re: [opensuse] redis
On Wed, 06 Mar 2019 23:28:59 +0100
Per Jessen <per@xxxxxxxxxxxx> wrote:

Dave Howorth wrote:

On Wed, 6 Mar 2019 19:49:03 +0000
Dave Howorth <dave@xxxxxxxxxxxxxx> wrote:

On Wed, 06 Mar 2019 19:07:14 +0100
Per Jessen <per@xxxxxxxxxxxx> wrote:

Dave Howorth wrote:

So a little more information. I've now got it running under
systemd as I mentioned above but apparently it's running as a
service called redis@default as mentioned by Per earlier.

Now emoncms is still claiming it isn't running, even though
I've separately run the PHP code it uses to check and that
works fine. Every other test indicates that both redis and the
Phpredis extension are working fine.

The only thing I can see that is different is that emoncms
expects the redis service to be called redis-server, not
redis@default.

Those are just names, emoncms is likely looking for a port or a
unix
service. There must some config for emoncms too?

Thanks Per. emoncms is expecting it on the standard port -
127.0.0.1:6379 - which it is on. What's a unix service?

To add, the point is that on raspbian (and presumably ubuntu and
debian also) the service is called 'redis-server' rather than
'redis@default' so the various scripts that try to access
redis-server status and suchlike will fail on openSUSE.

The idea is that tou can have multiple redis instances, just as you
can with mysql, postfix, vpn and many other services. Scripts that
rely on a hardcoded name of a systemd service and fail - it's their
problem.

Well right, and I've made that point to them but in the meantime I've
got the problem of getting the existing software to run.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >