Mailinglist Archive: opensuse (389 mails)

< Previous Next >
Re: [opensuse] redis
On Mon, 4 Mar 2019 11:41:30 +0000
Dave Howorth <dave@xxxxxxxxxxxxxx> wrote:

On Sun, 3 Mar 2019 17:29:09 -0600
"Jeffrey L. Taylor" <jeff.taylor@xxxxxxxx> wrote:

Quoting Dave Howorth <dave@xxxxxxxxxxxxxx>:
I just installed redis 4.0.10-lp150.3.3.1 from openSUSE Leap 15.0
repository but I can't figure out how to start/use it.

I installed it to use with a system called emoncms but that says:
"redis enabled but not installed"

I tried redis-cli:

$ redis-cli
Could not connect to Redis at 127.0.0.1:6379: Connection refused
Could not connect to Redis at 127.0.0.1:6379: Connection refused
not connected>

same if I try as root.

$ systemctl status redis
Unit redis.service could not be found.

I found something similar on 42.3. I can start redis manually with
the example configuration modified for the app I'm using it with.

# redis-server /etc/redis/amethyst.conf

Ah ha. # redis-server default.conf runs and afterwards

$ redis-cli
127.0.0.1:6379>

so I guess it is running. emoncms is still giving me the same error
though, so I'm not out of the woods yet.

Thanks anyway. Some progress at least.

Starting it with systemctl fails with messages similar to what you
see on 15.0. I have not successfully debugged why. It's for a
local application, I can restart it manually.

HTH,
Jeffrey

So a little more information. I've now got it running under systemd as
I mentioned above but apparently it's running as a service called
redis@default as mentioned by Per earlier.

Now emoncms is still claiming it isn't running, even though I've
separately run the PHP code it uses to check and that works fine. Every
other test indicates that both redis and the Phpredis extension are
working fine.

The only thing I can see that is different is that emoncms expects the
redis service to be called redis-server, not redis@default. So I'd like
to see if I can start redis with that service name as an experiment,
but I can't see how to do that. Does anybody know? How does the systemd
service mechanism work with regards to getting the name of a service?

TIA, Dave

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >