Mailinglist Archive: opensuse (389 mails)

< Previous Next >
Re: [opensuse] Probably OT but just in case ...
On 02/03/2019 21:40, Stevens wrote:
My system: Leap15 / Plasma 5

I have been trying unsuccessfully to play dvds on this new system.
Tried all the usual but nothing worked, then started on the
not-so-usual. My system would see everything on the dvd drive
but vlc wouldn't play the video. After further digging it seemed
that it wasn't passing region check. More digging turned up the
following, "The problem is that a lot of newer drives are RPC2 drives
these days. Some of these drives don't allow raw access to the drive
until the drive firmware has done a region check. VLC uses libdvdcss and
it needs raw access to the DVD drive to crack the encryption key"

So, I removed the little slim drive (mfg date June 2012) and connected a
full sized LG drive from March 2010 and now everything works just fine
except the cover won't fit. Maybe a usb to sata converter and go outboard?

Question now is how do I find a slim dvd drive that will fit in this
mini-itx case that is also RPC-1? Or, how do I find a dvdcss equivalent
that works with an RPC-2 drive?

Can't provide an answer, just some commentary. Having played DVDs on
openSUSE since around 2004, I'd not done so under Leap 42.3, until
recently. When I tried both home-recorded and pre-recorded DVDs on two
different 42.3 systems - one laptop and one desktop - using either VLC,
Dragon Player or SMPlayer, in some cases I'd get the opening DVD title
sequence but none of them could navigate the menus, by either mouse or
keyboard, or play anything. This discs play fine on hardware DVD
players. I suppose there could be a missing codec but I've always had a
large bunch of codecs from Packman installed on every openSUSE system
until now; this seemed more like some other issue.

gumb

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References