Mailinglist Archive: opensuse (626 mails)

< Previous Next >
Re: [opensuse] trouble with ssh connecting
* George from the tribe <tech@xxxxxxxxxxxxxxxxxx> [11-13-18 18:24]:
On 11/12/18 10:15 PM, Patrick Shanahan wrote:


yast sysconfig
search for ssh
enable it for FW_SERVICES_ACCEPT_EXT

systemctl restart SuSEfirewall2

worked for me


Patrick you are AWESOME. That totally worked! Thanks!
Although I could not find it in yast, so I went into the file
/etc/sysconfig/SuSEfirewall2 and found that line, and made it look like
this:
FW_SERVICES_ACCEPT_EXT="0.0.0.0/0,tcp,22"

I restarted the firewall and immediately I got ssh connection back. I saw on
an openSUSE page that setting the line like that means that only ipv4
connections will work. Well, it also allowed my connection to be reset.

Oh I might mention I only had to do this on one computer, my bigger laptop,
the one I was trying to connect to. I didn't make any changes on the smaller
laptop, the one I was trying to connect from.

the problem comes from the dropped support for SuSEfirewall2, in this case
update scripts from openssh and yast, iiuc. 42.2 is on my server and
eventially I will have to deal with it but would prefer not changing until
I update the system.

there is firewalld and the SuSEfirewall2 conversion script to firewalld
available. and I have used it on a Tw machine successfully, but do not
know if I trust it completely for my server with mail, ssh and web
servers. and I have a large contingency of ipset bans I would like to
continue plus some custom adds to SuSEfirewall2/iptables.

--
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri
http://en.opensuse.org openSUSE Community Member facebook/ptilopteri
Registered Linux User #207535 @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo paka @ IRCnet freenode

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >