Mailinglist Archive: opensuse (626 mails)

< Previous Next >
Re: [opensuse] missing fonts on upgrade to TW
On 12/11/2018 03.14, George from the tribe wrote:
So on my laptop that I had Leap 15 installed on, I decided to try
upgrading to tumbleweed by means of zypper dup. It worked well on my
other laptop, so I tried it on this one.

After I replaced all the repositories with TW repositories, I ran the
zypper dup and it downloaded everything just fine. Then in the middle of
the installation, it lost internet connection, and then could not run
the script from fetchmsttfonts to download microsoft fonts available on
sourceforge.

It is possible that other packages were not installed, so run "zypper
dup" again.

The following command failed:

fetchmsttfonts-11.4-22.3-fetchmsttfonts.sh.txt

I had to hit "ignore" to keep the installation going. I am now in the
new system with fixed internet, but I don't know how to actually run the
script from this package.

This shows the package that is installed, but how do I figure out what
to do next? I can't find anywhere that tells me how to run the script
manually when it is not being run by zypper.

# rpm -qa | grep fetchmsttfonts
fetchmsttfonts-11.4-22.3.noarch

Any help would be greatly appreciated.


If you do "rpm -ql fetchmsttfonts" you will see the files it contains,
and of it will be the actual script
"fetchmsttfonts-11.4-22.3-fetchmsttfonts.sh.txt". Just run it.

Alternatively, uninstall the package and reinstall it. Perhaps force
update also does the trick.

--
Cheers / Saludos,

Carlos E. R.
(from 42.3 x86_64 "Malachite" at Telcontar)

< Previous Next >