Mailinglist Archive: opensuse (1108 mails)

< Previous Next >
Re: [opensuse] how to add a group?
On Tue, 7 Aug 2018 00:07:11 +0100
Dave Howorth <dave@xxxxxxxxxxxxxx> wrote:

On Mon, 6 Aug 2018 16:43:19 -0400
David T-G <davidtg-robot@xxxxxxxxxxxxxxx> wrote:

Dave, et al --

...and then Dave Howorth said...
%
% I need to create a new group - 'plugdev' - and make my user a
member of % the group (it's apparently necessary for android dev
tools). ...
%
% $ id
% uid=1000(dhoworth) gid=100(users) groups=100(users),16(dialout)
...
% Ah, if I su to myself then
%
% $ groups
% users dialout plugdev
%
...
% Gah! I must be missing something basic.

Basic, yes, but not necessarily well known. I'll be that you ran

su - ..

Not sure exactly what you meant there but I did su, not su -

to become yourself so that you effected a login shell, which is what
you need to read your groupship. You can either log out and log in
again or just ssh to your machine in that window and you'll then
have the plugdev group in that shell.

But I just tried su - and I just tried ssh and neither affected the
outcome. groups tells me I am a member, adb tells me I am not.

I'm not intending to log out, unless somebody convinces me it really
is necessary for some obscure linux reason. :)

Ah! Success, or at least a step along the road.

There is no need to start a new terminal or to logout.

It's not a linux thing at all. It's adb. It's necessary to run

$ ./adb kill-server
$ ./adb -a devices

Now I just need to understand the arcane-ness of udev rules :(

Oh, BTW, it seems plugdev is a built-in group on debian. I don't think
we have the same on opensuse.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups