Mailinglist Archive: opensuse (1352 mails)

< Previous Next >
Re: [opensuse] KGPG : Serious fault
  • From: "Knurpht @ openSUSE" <knurpht@xxxxxxxxxxxx>
  • Date: Sun, 03 Jun 2018 20:22:51 +0200
  • Message-id: <1719087.hdxEUSNInC@knurpht-hp>
Op zondag 3 juni 2018 20:14:39 CEST schreef Anton Aylward:
On 03/06/18 10:43 AM, David C. Rankin wrote:
There may be a mismatch in your pinentry package, You have 3 (maybe 4)
options. On 42.3 you have

pinentry
pinentry-gtk2
pinentry-qt4

Well DUH!

/usrbin/pinrentry is a script.
Therein is code to detect what desktop you are using.
If it is looking for KDE4 and you are using KDE5 then you have a problem.
See line 47. Change that 4 to 5

If that doesn't match,the code for running kde drops though to try to use
"pinentry-qt" but

# which pinentry-qt
which: no pinentry-qt in
(/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr
/bin/X11:/usr/games)

You could, of course link pinetry-qt to pinetry-qt4

Hmm.
I suppose you could recode it to check for either 4 or 5 ....

Perhaps this should be a bug report, but isn't that up to the TW or "15"
people? I'm only 4running 42.3 so I don't think they will listen to me.
Of course report a bug, 42.3 is still maintained and supported, it might even
be that the bug is in Leap 15 and TW as well.


--
Gertjan Lettink a.k.a. Knurpht
openSUSE Board Member
openSUSE Forums Team



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >