Mailinglist Archive: opensuse (794 mails)

< Previous Next >
[opensuse] conflict between nut and apcupsd - really?
  • From: Peter Suetterlin <P.Suetterlin@xxxxxxxxxxxx>
  • Date: Wed, 29 Nov 2017 13:43:51 +0000
  • Message-id: <20171129134351.fhyfjnzti5ask2u7@woodstock.pitnet>

Hi list,

it seems nut and apcupsd refuse to be installed at the same time. The nut
package lists a conflict with apcupsd, apcupsd itself seems not to care.

This is strange, as I cannot find a real collision between the two packages?

Digging into this 'conflict' I found a notice on the debian list that nut
needs to conflict with apcupsd because both use /etc/init.d/ups-monitor.

Now that is somewhat ridiculous in itself (rather rename init scripts or use
alternatives I'd say), but for recent OS systems the file isn't there at all
and all systemd stuff seems to use 'personalized' commands.

So is - as I assume - this collision only a historical one that should be
removed?

I really want both installed, not for monitoring, but for maintainance of
UPSes (we have many, of various brands, and nut does not support all commands
on APC units...)

Still googling around to find out how to override that conflict. Is there
one, or do I have to unpack the rpm manually and install it without knowledge
of the packet manager?

Pit

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >