Mailinglist Archive: opensuse (795 mails)

< Previous Next >
[opensuse] alsa-mixer.c: Failed to set switch of Speaker: Input/output error
  • From: listreader <suselist@xxxxxxxxxxxx>
  • Date: Mon, 20 Nov 2017 03:11:41 -0600
  • Message-id: <20171120031141.528f1754@msb6dell.privatesite>
Brand new Dell Precision Workstation T3620 Mini Tower. I installed Leap
423 with an XFCE desktop and was working fine. Until today. Multiple
hiccups. Don't know whether they are related or not so I'll post them
in separate threads. This is 2-of-2:

I had pulseaudio installed. The speaker would switch off. Checking I
found that pulseaudio had switched to "headphones (plugged in)" which
they were not, and "speakers" showed as "not available". I used yast2
sound module to reset/reload the card. That works. Pulseaudio shows
speakers as live. Short time later, speakers go off again. Looking in
the journal I see...

"[alsa-sink-ALC3861 Analog] alsa-mixer.c: Failed to set switch of
Speaker: Input/output error"
"[alsa-sink-ALC3861 Analog] alsa-mixer.c: Failed to set switch of
Headphone: Input/output error"

...repeated multiple times in multiple places. I uninstalled
pulseaudio. Problems appear to be gone - no further speaker and
headphone switch problems either real or in journal. Sound is ok (but
very low volumn). But I'd like to put pulseaudio back for use with the
"Skype Preview" (i.e. beta) and etc. Any ideas what I should be
looking at? Thanks!

Ralph

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups