Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] "OpenSUSE" spelling in libreooffice [Was: openSUSE merits a better home page]
On 11/06/2017 09:48 AM, Carlos E. R. wrote:


On Monday, 2017-11-06 at 15:34 +0100, gumb wrote:
On 06/11/17 15:11, Carlos E. R. wrote:
I just tried in a new user (USA locale. Leap 42.2). I typed
"openSUSE" on
the blank page, pressed [ENTER], and instantly, the word was
converted to
OpenSUSE. I correct the first "O" to "o", go to the end of the
word, type
a space, and again the word is capitalized. It is a rule, the
first word
of a sentence must be capitalized, and at least in English, there
are no
exceptions, no method that I know to add exceptions.

In fact, "OpenSUSE" appears underlined in red, the speller says
there is
an error. One of the suggestions is in fact "openSUSE", and holds
as long
as you don't press "space" or [enter] close to the word. If there
is an
intermediate space the autocorrector does not trigger.

This has been known since ever.

I have not tried recently on a new user with Spanish locale, but I
could.

I think you have to do a Ctrl-Z (or whatever the Undo shortcut is in
your locale) straight after the autocorrect occurs to effectively tell
it to accept what you've typed.

Yes, but that first deletes the new line or the space you typed. As
soon as you add the space, because you need to separate words, you
know, it uppercases the word again.

The trick is to add the space or newline, let the autocorrection do
the thing, then go back to retype, then go to the end of the line
taking care not to press [space] or [enter] right close to the
"openSUSE" word.

It is more tricky on a calc sheet.



I just tried it. It only happens when openSUSE is the first word in the
sentence, where you'd normally have a capital on a word.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups