Mailinglist Archive: opensuse (795 mails)

< Previous Next >
Re: [opensuse] leap42.3 as xen host - wants to install gtk3 ?
Andrei Borzenkov composed on 2017-11-01 06:40 (UTC+0300):

For instance:
gtk3-immodule-amharic
gtk3-immodule-inuktitut
gtk3-immodule-thai
gtk3-immodule-vietnamese

Those are pulled in by supplements, so you should be able to remove and
lock them.

They are pulled in by error :).

They have been a nuisance inclusion among my zypper locks for years. There's
nothing I can do with CJK lang, glyph or locale. I use none of Gnome/GTK that
isn't required by Mozilla apps. en_US is the entirety of my vocabulary.

# zypper ll
...
56 | gtk2-immodule* | package | (any)
57 | gtk3-immodule* | package | (any)

That's certainly possible. Condition to install them is "gtk3 and
corresponding language". I do not know how exactly "language requested
by user" is represented in libsolv, I /think/ that something must
provide locale(am) (as example), but on my 42.3 nothing provides it
still these packages are installed.
AFAIK there is a open bug, since
openSUSE 13.1 or so.

Do you happen to have the number?
I looked. Only https://bugzilla.opensuse.org/show_bug.cgi?id=799571 among last
60 months' activity contains string immodule in summary. Changing search to gtk*
components and immodule in comments times out or produces other fatal BZ errors.
--
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation