Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] rootmail does not work, no matter what
On 09/24/2017 01:27 PM, stakanov wrote:
In data domenica 24 settembre 2017 11:01:23 CEST, Bruce Ferrell ha scritto:
On 09/24/2017 12:59 AM, stakanov wrote:
In data domenica 24 settembre 2017 09:25:51 CEST, Per Jessen ha scritto:
stakanov wrote:
I have the following:
[snip]

#
# IP-Address Full-Qualified-Hostname Short-Hostname
#

127.0.0.1 localhost
I propose one of three solutions -

a) amend /etc/postfix/main.cf:

[default at install time]
inet_interfaces = localhost
inet_protocols = all

[new settings]
inet_interfaces = localhost
inet_protocols = ipv4

b) Remove the line with '::1' from /etc/hosts.

c) re-enable IPv6


That's all there is to it.
I restored all settings to default.
I restarted the network with ipv6 enabled
I uncommented the ::1 from /etc/host as it is default

no rootmail

Should I raise a bug?
Here are some things you might want to check and ask yourself:

1.) Does the box process ANY mail? If so, it's not networking or address
resolution and probably not a gross issue with postfix configuration. Go
back to the basics.
Sorry I do not understand what you want to say with this. Process local mail?
Or process mail (like these mailinglists). I receive mail from the list as I
am writing from this pc. I am JUST not receiving rootmail at all.
2.) Have you checked file /etc/aliases for lines that looks something like
this:

# It is probably best to not work as user root and redirect all
# email to "root" to the address of a HUMAN who deals with this
# system's problems. Then you don't have to check for important
# email too often on the root account.
# The "\root" will make sure that email is also delivered to the
# root-account, but also forwared to the user "joe".
root: joe, \root
It is correctly set up and not commented out.
That file is used for just about any MTA you can think of. if the root:
line is commented, mail won't be forwarded. Uncomment it and run
newaliases.

3.) If you open a pair of terminal sessions and use a command line program
like mail to send an email, while tailing the mail log file, what does
postfix say is going on with that message?
Before it gave the message I posted at the beginning of the thread:
send-mail: fatal: parameter inet_interfaces: no local interface found for ::1
In the meanwhile I did reactivate ipv6 and... have still no rootmail.
Currently when I send mail via mail there is the black hole. No message in
rootmail but no error message of postfix.

My apologies.  I missed that.  If you aren't actually using ipv6, try this:

alter the file /etc/sysconfig/postfix

change this line:

POSTFIX_INET_PROTO=""

to

POSTFIX_INET_PROTO="ipv4"

and restart postfix




--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >