Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] some mp4 cannot be played "decoder profile above limits"


Am 23.09.2017 um 14:21 schrieb Dave Plater:


On 23/09/2017 11:43, Daniel Bauer wrote:

"Suddenly" the mp4-videos from my mobile phone cannot be played anymore, no matter what player I use: it only shows a black screen plus plays the sound, but no image.

...
I tried to start from commandline, and maybe the messages say something to somebody of you...:

vlc 20161005_085414.mp4
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[000055aac07500c8] core libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[00007f236c0b6378] vdpau_avcodec generic error: decoder profile above limits: level 51 3840x2160
[00007f236c0c48b8] freetype spu text error: Breaking unbreakable line
QObject::~QObject: Timers cannot be stopped from another thread

...


The first check is execute ffplay videofile and post the output line that starts with :"Stream #0:0(eng): Video:" it may have a different #0:0 numeral.
If ffplay works then vlc should but worst case you can convert it with ffmpeg.
Regards
Dave P


ffplay plays normal, the line you asked for is:

Stream #0:0(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 3840x2160, 48327 kb/s, 29.98 fps, 30 tbr, 90k tbn, 180k tbc (default)

Yes, I could convert them, but I use vlc to look thru the videos deciding which ones I want to convert for web-use etc., to take screen shots an the like. It worked before with those videos...

--
Daniel Bauer photographer Basel Barcelona
https://www.patreon.com/danielbauer
http://www.daniel-bauer.com

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >