Mailinglist Archive: opensuse (946 mails)

< Previous Next >
Re: [opensuse] some mp4 cannot be played "decoder profile above limits"


On 23/09/2017 11:43, Daniel Bauer wrote:
Hi everybody

"Suddenly" the mp4-videos from my mobile phone cannot be played anymore, no matter what player I use: it only shows a black screen plus plays the sound, but no image.

As for my small tests it only affects the mp4 from my samsung mobile that are larger than 10MB (9.8MB works, 11.2MB does not work, neither larger). But downloaded mp4, avi, etc. work normally even in GB size.

I tried to start from commandline, and maybe the messages say something to somebody of you...:

vlc 20161005_085414.mp4
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[000055aac07500c8] core libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[00007f236c0b6378] vdpau_avcodec generic error: decoder profile above limits: level 51 3840x2160
[00007f236c0c48b8] freetype spu text error: Breaking unbreakable line
QObject::~QObject: Timers cannot be stopped from another thread

I see a limit, but don't know where I can change this limit. Everything worked a few weeks ago with the same system, but meanwhile there were some updates and of course I have no idea which one changed that...

Leap 42.3
KDE 5.8.7
Kernel 4.4.87-25 default
Latest "zypper up" done 5 minutes ago.

All "media-things" installed from packman.

Any hints? Thanks!

Daniel


The first check is execute ffplay videofile and post the output line that starts with :"Stream #0:0(eng): Video:" it may have a different #0:0 numeral.
If ffplay works then vlc should but worst case you can convert it with ffmpeg.
Regards
Dave P

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References