Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
Re: [opensuse] Re: Where is default browser set? (& hope no one is logged in via WiFi)
On 2017-06-22 06:00, L A Walsh wrote:
Carlos E. R. wrote:
On 2017-06-22 01:13, L A Walsh wrote:

I've never seen this behavior.

Well, somehow that is not surprising. You customize a lot your systems,
they depart too much from the standard.

---
Having a desktop running Windows, logging into a *nix machine
isn't exactly what most people would classify as "customizing", though
that I'm not running an X11 based browser on Windows _may_
be the reason I'm not seeing this behavior (I don't know of any X11
browsers that do run on Windows, offhand).

Well, you did not say you were not using Linux. One, when posting here,
assumes you are unless you say otherwise.


Some of these crazy statements about what I run are baseless and
often contrary to what is actually true. Just like someone from
some suse list who thought I ran some "huge monolithic kernel" (no
doubt trying to reference my, accurate, statements about sysd). It was
also claimed I blamed sysd for every little problem: not only not
true, but impossible as I don't run it.

The _reality_ on the "huge monolithic kernel", with 8% of the
loadable module total, built-in, my kernel was still 30% smaller than
any of the kernels they were comparing it to.

From what I recall, you do customizations to not use initrd ram disk.
That's a big modification. I have not said you use a "huge monolithic
kernel".


Too many people have misperceptions about my practices/setup
that differ from reality which is unavoidable, but what is avoidable is
them broadcasting those distortions to others causing no end of
problems. You, Carlos, should know better.

I know, from many posts, that you depart from the defaults a lot, for
whatever reasons. I don't judge. But we have to be aware of that when
talking because we assume things should work in a certain way and they
don't because you modified something.

It is not the case this time, it doesn't work for you because you are
not using Linux on your client. Perhaps if you use Mobaxterm instead of
Putty it would. Unsure.


**remote control of unix mozilla**

[Borrowed from the 4.x x-remote doc]

---
The document(s) I can find about remote control (searching on
your keywords) date back almost 10 years and don't mention
firefox (ex.: https://www-archive.mozilla.org/unix/remote.html).
It *seems* they may only be applicable to browsers run via X (which
would exclude my Windows-based browsers).

Yes, it mentions firefox. Notice the command line:

Syntax of mozilla-xremote-client:


mozilla-xremote-client [-a firefox|thunderbird|mozilla|any] [-u ] [-p
] COMMAND


«When Netscape Navigator is invoked with the -remote argument, it does
not open a window, but instead connects to and controls an
already-existing process. The argument to the -remote switch is an Xt
action to invoke, with optional arguments.»

«Remote control is implemented using X properties, so the two processes
need not be running on the same machine, and need not share a file
system.»

What website did you get that from? I'd like to look at it -- who knows, I
might be able to use a working X11 setup to do that to proxy commands into
a non-X environment. (though it also might be too much work).


https://www-archive.mozilla.org/unix/remote.html

the one you posted above.

which seems to be extracted from
"http://home.netscape.com/newsref/std/x-remote.html";, which is currently
dead. Well, not dead, taken.

--
Cheers / Saludos,

Carlos E. R.
(from 42.2 x86_64 "Malachite" at Telcontar)

< Previous Next >
Follow Ups