Mailinglist Archive: opensuse (1264 mails)

< Previous Next >
Re: [opensuse] Re: Where is default browser set? (& hope no one is logged in via WiFi)
On 06/21/2017 04:09 AM, Carlos E. R. wrote:
Maybe John has that sort of stuff in his profile, that would explain why
his setup reacts differently. I can only confirm the behaviour Carlos
has described, even across widely varying openSUSE's. To get a remote
firefox, I had to use '-no-remote' which gives me a much slower
firefox, the host machine is also indicated in the windows
title "Mozilla Firefox <@office34>".
Exactly.

And it has been that way for ages. I found about this "feature" the
first time I tried, expecting to get the server machine Firefox, and I
had to ask here about this strange thing, and I was told that Firefox
works that way, and to use "-no-remote" to disable.

I have no such settings in my profile, i've greped it, looked
at firefox startup command lines, firefox profiles, etc. Can't find
any such setting.

I think there has to be more going on here than just a firefox setting.

This sounds like a HUGE security flaw, if firefox can reach back across
the ssh connection into my local machine, and feel around for an
instance of itself (running or not) and launch it locally when I asked
it to run remotely.

There is something horribly broken about that. I'm glad it doesn't work for me.

I'd be interested to see just what ssh options allow this, so that
I can make a mental note never to turn them on.


--
After all is said and done, more is said than done.

< Previous Next >