Mailinglist Archive: opensuse (1256 mails)

< Previous Next >
[opensuse] can no longer select 4x6in photo for printing
Visiting parents. Their Leap 42.2 machine running KDE has an annoying new issue. I don't know for sure if this came about after the upgrade from 42.1 to 42.2 (done around the new year) or following a more recent update.

The printer is an old HP PSC 2410 (PSC 2400 series) multifunction device. It should, and has always for the last dozen years, printed any size or quality up to A4, including 4x6in or 5x7in photos (with or without tab/border). Now, when going to print from any application, trying to select these options from the drop-down list fails. They are there in the list but clicking them is ignored and it reverts to A4. Some similar options such as 148x105mm can be selected.

I tried changing the ppd in YaST, in the Cups web interface or in hp-setup from hpcups to hpijs. Although this changes some of the items in the paper size list, equivalent options such as 'Photo or 4x6in index card' still cannot be selected.

Vaguely recalling mentions on this ML from others trying out the hplip packages direct from the project's website, I followed the instructions there to download and install the latest version 3.17.4 for openSUSE 42.2, agreeing during the process to remove previous versions and reinstall. After all that, still the same problem persists.

Here's the ppd file that's in /etc/cups/ppd:
http://paste.opensuse.org/17473252

what is responsible for enforcing the paper sizes, this ppd file or something else? Skimming through it, I don't see anything obviously wrong but I'm not an expert.

gumb

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups