Mailinglist Archive: opensuse (527 mails)

< Previous Next >
Re: [opensuse] A puzzle for the weekend
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Sat, 13 Aug 2016 10:47:35 +0200
  • Message-id: <nommr7$tvt$1@saturn.local.net>
Per Jessen wrote:

Some other possibilites:
- nscd issues?

I did think of that one, and did "nscd -i hosts" - however, ping will
also use nscd, and that works.

- Maybe wget handles ipv4/v6 stupidly? Try wget -4.

Ah, forgot about that one. Yes! that was it.

Well, it seems to be something happening between wget and nscd.
Without '-4', I see wget talk to nscd via /var/run/nscd/socket after
which it says "Resolving ... failed: Name or service not known.".

Somehow nscd has a cache-entry that always says "not found". I've tried
with "nscd -i hosts", but it doesn't seem to do anything. When I run
wget with -4, it also talks to nscd, but obviously gets a better
answer. It seems pretty clear that nscd is the culprit here. I'll
just restart it, trying to identify the actual problem is probably
pointless.


--
Per Jessen, Zürich (17.9°C)
http://www.dns24.ch/ - your free DNS host, made in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >