Mailinglist Archive: opensuse (527 mails)

< Previous Next >
SOLVED Re: [opensuse] glib.h triggers new error: /usr/include/pthread.h:1000:58: error: expected ‘;’, ‘,’ or ‘)’ before ‘__cond’
On 08/09/2016 10:44 PM, Andrei Borzenkov wrote:
10.08.2016 05:55, David C. Rankin пишет:
/usr/include/pthread.h:1000:58: error: expected ‘;’, ‘,’ or ‘)’ before
‘__cond’
extern int pthread_cond_wait (pthread_cond_t *__rdstrict __cond,
Is it really __rDstrict? It is suposed to be __rEstrict.

...

Yes, really is...



(side note: it also disclosed glib's abuse of enum in
/usr/include/glib-2.0/gobject/gparam.h with

G_PARAM_DEPRECATED = 1 << 31

which is definitely not an 'int' constant [by +1])
What it is? Floating point? String?

INT_MAX = (1 << 31) - 1;

Evidently the shifts 0-30 were used and instead of finding some nice number in
the range of int, they just shifted by 31 and left it.

The solved part of the response can be chocked up to a big "I have no clue what
was broke", but `zypper up -r update` pulled in an update for pcre-tools, and
attempting the build again -- worked fine.

So all is well again.

--
David C. Rankin, J.D.,P.E.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >