Mailinglist Archive: opensuse (527 mails)

< Previous Next >
[opensuse] Trying to get HP 1110 printer and Canon Pixma MG 2470 scanner working under OpenSuse
Hi,

I am an OpenSuse newbie migrating from Windows XP. I am running OpenSuse
42.1 Leap (amd64) with HP 1110 printer and Canon Pixma MG 2470 scanner.
I wish to get both these devices working.

I ran hp-doctor which fixed all required dependencies. When I run
hp-setup, I get the error "No devices found on bus usb". I have a HP
1110 queue in CUPS, as seen in the web browser interface. Printing from
X clients like gedit to the CUPS printer queue returns with the message
"Printing completed", but no printout actually emerges from the printer.
Nor do the LED lights on the printer blink to show any data reception.

When, as root, I run 'scanimage -L', I get "No scanners were
identified". Running sane-find-scanner, I get :

found USB scanner (vendor=0x04a9 [Canon], product=0x176c
[MG2400 series]) at libusb:003:009
could not fetch string descriptor: Pipe error

'lsusb' gives me :
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 005: ID 258a:0001
Bus 003 Device 004: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 003 Device 003: ID 051d:0002 American Power Conversion
Uninterruptible Power Supply
Bus 003 Device 002: ID 214b:7000
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0480:a202 Toshiba America Info. Systems, Inc.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 093a:2521 Pixart Imaging, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thanks for any help.
Manish Jain

< Previous Next >
Follow Ups