Mailinglist Archive: opensuse (769 mails)

< Previous Next >
[opensuse] Kernel won't load properly, touchpad won't work
Hi,
my laptop which I carry with me on business trips died, and I
purchased a new laptop. Its an ASUS Q303UA, and I loaded
opensuse Leap 42.1 on it today.

It has one issue with hardware, the touchpad isn't recognized.
I tried to find some info about how to fix this and the long
and short of it is that Ubuntu guys say that the driver is in
kernel 4.5x and after. The kernel which is loaded at the
opensuse 42.1 install is 4.1.21-14-default.

I tried to install a newer kernel, 4.6.0-4.g2a4d959-default
first from this repository:
http://download.opensuse.org/repositories/Kernel:/stable/standard/

However, when I try to boot with that kernel, I get the following
message:

Loading linux 4.6.0-4.g2a4d959-default ...

error: /boot/vmlinuz-4.6.0-4.g2a4d959-default has invalid
signature. Loading initial ramdisk ...
error: You need to load the kernel first.

Press any key to continue.

I next removed the 4.6 kernel from that repository, and changed
repositories to the following:

http://download.opensuse.org/repositories/Kernel:/HEAD/standard/x86_64/

I installed kernel 4.6.0-4.1.g779b2fc-default, then rebooted. When I
tried to boot with this 4.6 kernel, I get the same message as above
with the other 4.6 kernel.

I decided to try to put a lower kernel than that which was installed
during the installation, and installed kernel-default 4.1.20-11
-default. With this kernel I can boot normally without any error
message.

I don't know how to get the 4.6 kernels to load to see if that
will fix the touchpad problem. Maybe there is another way to
get the touchpad working, but I am not aware of it.

Does someone recognize these problems that can advise me of a
solution?

Thanks,
Mark





--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >