Mailinglist Archive: opensuse (769 mails)

< Previous Next >
Re: [opensuse] System is booting up. See pam_nologin(8)
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Mon, 16 May 2016 15:09:23 +0200
  • Message-id: <nhcgq3$ab2$1@saturn.local.net>
Andrei Borzenkov wrote:

16.05.2016 14:29, Per Jessen пишет:
Per Jessen wrote:

Andrei Borzenkov wrote:

16.05.2016 13:53, Per Jessen пишет:
Anton Aylward wrote:

On 05/16/2016 05:27 AM, Per Jessen wrote:
I upgraded/patched a 13.2 xen guest just now and after
rebooting, I
see $SUBJ when I login via ssh. What does $SUBJ mean?

/run/nologin exists.

What is the ownership/permission and the contents of that file?

# ls -l /run/nologin
-rw-r--r-- 1 root root 40 May 16 11:26 /run/nologin

I presume you've read the nologin man page?
http://man7.org/linux/man-pages/man8/pam_nologin.8.html

Yes, but it offers no clue as to why this suddenly started
happening.


Normally it should be removed by systemd-user-sessions.service on
bootup. If you remove this file and reboot - does it appear again?

Just tried that, the file did not appear again. Weird.

Seems it is not being removed -

192.168.2.132:/run # touch nologin
192.168.2.132:/run # ls -l /run/nologin
-rw-r--r-- 1 root root 0 May 16 13:24 /run/nologin
192.168.2.132:/run # reboot
Connection to 192.168.2.132 closed by remote host.
Connection to 192.168.2.132 closed.
per@io64:~> ssh root@192.168.2.132
System is booting up. See pam_nologin(8)


Is file still the same? pam_nologin displays content of this file and
you created empty file. Does it still have the same modification time
and is empty?

It is no longer empty, it now has the message from above. Timestamp
looks the same, but I'll try it again.


--
Per Jessen, Zürich (12.6°C)
http://www.dns24.ch/ - your free DNS host, made in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >