Mailinglist Archive: opensuse (769 mails)

< Previous Next >
[opensuse] zypper seems to pick the wrong package version
Greetings,

I'm trying to install a package, which has a dependency on package "A >= version". The repository has package
"A" with several versions, including "version" and "version+1". I would expect "version+1"
to be installed, but that is not happening. Am I misunderstanding something about the dependency resolution?

More specifically:
--
# zypper --version
zypper 1.12.37

# rpm -q -p --requires ./ibm-sdk-lop-remote-dependencies-1.9.0-1.ppc64le.rpm
glibc >= 2.13
make
fdprpro >= 5.6.2-7
fdpr_wrap >= 0.1.1-4
advance-toolchain-devel >= 8.0-5
advance-toolchain-perf >= 8.0-5
automake
autoconf
libtool
gettext
pthread-mon >= 0.5.11-1
git
perf
gdb
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadIsLzma) <= 4.4.6-1

# zypper search --provides 'advance-toolchain-devel >= 8.0-5'
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+-------------------------------+---------+---------+---------+------------------
| advance-toolchain-at8.0-devel | package | 8.0-6 | ppc64le | Advance
Toolchain
| advance-toolchain-at8.0-devel | package | 8.0-5 | ppc64le | Advance
Toolchain
| advance-toolchain-at8.0-devel | package | 8.0-4 | ppc64le | Advance
Toolchain
| advance-toolchain-at8.0-devel | package | 8.0-3 | ppc64le | Advance
Toolchain
| advance-toolchain-at8.0-devel | package | 8.0-2 | ppc64le | Advance
Toolchain
| advance-toolchain-at8.0-devel | package | 8.0-1 | ppc64le | Advance
Toolchain
| advance-toolchain-at9.0-devel | package | 9.0-3 | ppc64le | Advance
Toolchain
| advance-toolchain-at9.0-devel | package | 9.0-2 | ppc64le | Advance
Toolchain
| advance-toolchain-at9.0-devel | package | 9.0-1 | ppc64le | Advance
Toolchain
| advance-toolchain-at9.0-devel | package | 9.0-0 | ppc64le | Advance
Toolchain

# zypper install --dry-run ./ibm-sdk-lop-remote-dependencies-1.9.0-1.ppc64le.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 4 NEW packages are going to be installed:
advance-toolchain-at8.0-devel advance-toolchain-at8.0-perf
advance-toolchain-at8.0-runtime ibm-sdk-lop-remote-dependencies

The following 4 packages are not supported by their vendor:
advance-toolchain-at8.0-devel advance-toolchain-at8.0-perf
advance-toolchain-at8.0-runtime ibm-sdk-lop-remote-dependencies

4 new packages to install.
Overall download size: 408.3 MiB. Already cached: 0 B. After the operation,
additional 1.8 GiB will be used.
Continue? [y/n/? shows all options] (y): n
--

Regards,
Paul Clarke

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups