Mailinglist Archive: opensuse (1470 mails)

< Previous Next >
[opensuse] Older install won't boot
Greetings. I have two older installs on one machine, neither will now boot up. Different issues I believe. The first install is openSuse 11.4. Second is 12.3. These are on the same physical disc, both on separate partitions under an extended partition on that disk. 11.4 is on /dev/sda5, and 12.3 is on /dev/sda6. I used this setup to migrate from one install to another over time, keeping everything under / on each separate partition.

The 11.4 install was working fine, and I installed 12.3 on /dev/sda6 overwriting the previous install that was there, I don't recall which version of openSuse was there. But 12.3 brought along Grub2.

So to separate the 2 different issues.

1. Originally after a new clean install of 12.3, the 11.4 install worked fine and I had that set as the boot default. I seem to recall I had to manually set Grub2 to boot the 11.4 install but got that working. The 12.1 installed worked fine. After some time, the 11.4 install would not always boot, giving an error stating:

"booting openSUSE 11.4 (x86_64) (on /dev/sda5)
error: file /vmlinuz-3.0.101-71-desktop not found
error: you need to load the kernel first.

Press any key to continue..."

The thing is, sometimes it would boot, other times not. But it has not booted in a long time now. Many months.

2. As stated the 12.3 install was working fine. Recently, after I select that install to boot in the Grub2 menu, it says 'doing fast boot', then proceeds, but does not get past the green bush with Cammie on it. It starts out muted green and gets brighter, but never proceeds past that. I suspect that this is a disk issue. I ran Spinrite on it to check the physical disk on that partition and all the others on that drive, no issues shown. I booted the opensuse 12.3 install disk, and ran rescue system and ran 'e2fsck -f -y -v /dev/sda6' which says that the file system was modified. System still did not boot. I ran e2fsck twice again, the first showed file system modified, second time not, but it still won't boot, hangs in process as before. Both partitions are EXT4. I do have /dev/sda5 set to mount on boot of the 12.3 install, as well as another physical drive, not sure if this could freeze the boot process or not.

Most of my files are on the 11.4 install partition, and I intend to overwrite the 12.3 install with leap 42, but wanted to get either install to boot to look around first. Any pointers most welcome.

Thanks,

Jim F
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >