Mailinglist Archive: opensuse (1467 mails)

< Previous Next >
Re: [opensuse] Need distro advice. Problems installing Leap.
On 02/10/2016 03:13 AM, Per Jessen wrote:
Jim Sabatke wrote:

On Feb 10, 2016, at 1:14 AM, Per Jessen <per@xxxxxxxxxxxx> wrote:

Jim Sabatke wrote:

OK, I've done two installs and both had almost the exact same
problems, they wouldn't reboot after the install. I've really never
had a problem installing a SuSE distro until Leap. The first was on
my desktop, which has 4 SATA drives. I initially used the
installer's
recommended configuration, with / on sda and /home on sda. That
refused to boot, with a blank screen on reboot, until I put /home on
sda. Then it went perfectly.
That sounds totally odd. I think it's highly unlikely that this has
actually to do with what's being mounted where.
I mistyped, or more likely, my iPad auto-corrected my /sdc to /sda. To clarify, the Leap install wanted to put / and /home on /sdc, which is a 1 TB drive. The install worked perfectly after moving / to sda. That was the only difference in my installs. It's an older desktop with BIOS that supported Windows 3.1 when I bought the machine. I'm guessing I had a disk size problem, but I'm not sure, and I can't really go back and tell what happened or what might have worked on the blank, unresponsive screen. To clarify, for those confused by that, by blank I mean no graphics or characters, totally black. I wouldn't have bothered to write about this one since I did get it working. With the reboot, before the system started, I did get the input for BIOS or UEFI. I selected BIOS.

However, the laptop sitting in my friend's house only has one drive, and it came with Windows 8.1. It acted the same, with a blank, unresponsive screen. I didn't have time to spend much debugging time, mostly because he has animals in the house that I'm pretty badly allergic to, so I need to kind of figure this out if I can, then get in and out as quickly as possible. I don't recall the exact disk size, but it was large, and I'm wondering if this is either a UEFI or disk size incompatibility. I've never dealt with UEFI as he had an older desktop before. When rebooting I tried selecting UEFI, but I got the disk not formatted error, and selecting BIOS simply hung the system with the same blank screen.

On both systems I have no means to ssh as they are the only Linux boxes in the house. I don't even have another Windows box to load ssh software onto to try it.

FWIW, I have two Leap systems -

a test desktop, nvidia graphics, boots from software raid1.
a server with very basic graphics, booting from iSCSI.

Then I tried to load Leap on a friend's laptop. He had only one
drive, so I figured it would be easy. Same problem on reboot with a
blank, unresponsive screen.
Sounds like a graphics issue, in both cases perhaps. You're an
experienced user - did you try switching to a virtual console,
Ctrl-Alt-F1 ? It's been a little while since I've dabbled with
difficult graphics cards, my desktops are all fairly backlevel
hardware-wise. Did you try using "nomodeset"?
First, thanks for the effort so far.

I tried the virtual console, no luck. I have a GeForce 9800 GT sound
card. Resolution is 1680x1050.
Sounds good except not being able to get to a virtual console is not so
good. If you google that card, you'll see some problems with it - I
wonder if blacklisting 'nouveau' might be worth trying.

If you can access the system via ssh, try removing 'nouveau', otherwise
you can blacklist it when you're booting: "BrokenModules=nouveau".

Some reference material:
https://en.opensuse.org/SDB:NVIDIA_the_hard_way#openSUSE_Tumbleweed_and_Leap

I did not try nomodeset. I'm about ready to try the other guy's laptop
as soon as he gets me some network info, so I'll try that if it
happens again. The laptop has Windows 8.1, does that provide any
challenges I may have missed?
I doubt it, but it's been years since I've dabbled in Windows.




--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >