Mailinglist Archive: opensuse (1451 mails)

< Previous Next >
RE: Re: [opensuse] 13.2 vs Leap vs Tumbleweed - Gnucash issue!
Hi Anton,

Interesting re: problems with Leap. I can comment however regarding one week's
success.

So FYI, the following has happened:

1. Stable (one week) Leap 42.1 install on Vultr VPS (1 GB) via SSH with VNC
access.
2. Running self-configured (Bitnami has a problem with OpenSuse) LAMP according
to X2CRM specifications, and then on top of that X2CRM (PHP). It works! I'm so
happy. And only (one or two tabs in Chrome - Midori doesn't seem necessary in
terms of not-bloated browsers) uses about 600 MB RAM.
3. And the bonus -- GnuCash seems to work out-of-the-box, and hardly adds any
RAM. Haven't really tried it though.

So, for $ USD 10 per month, this seems to be the target. This means I get to
turn off my slightly more expensive per month Canadian accounting online
package (Kashoo). And I get to enjoy X2CRM.

Lots of work to do to make a really robust system. Such as backups. I have also
a running copy of the setup on a VirtualBox running on my spare Optiplex. Also
need to do CRM mobile access. And make sure the security is good.

So, so far, so good!

John

-----Original Message-----
From: Anton Aylward [mailto:opensuse@xxxxxxxxxxxxxxxx]
Sent: February-06-16 10:11 PM
To: John Morris <jmorris@xxxxxxxxxxxxxxxxxx>
Subject: Fwd: Re: [opensuse] 13.2 vs Leap vs Tumbleweed - Gnucash issue!

GnuCash


-------- Forwarded Message --------
Subject: Re: [opensuse] 13.2 vs Leap vs Tumbleweed
Date: Sat, 6 Feb 2016 19:50:01 -0600
From: listreader <suselist@xxxxxxxxxxxx>
To: opensuse@xxxxxxxxxxxx

On Sat, 6 Feb 2016 21:34:25 +0100
Richard Brown wrote:

I state this not only from the legal perspective (Leap 42.1 is
published under the GPLv2) but also a technical one - only the above
repositories are build together, tested together, and therefore should
be assumed to work perfectly together

That assumption is unfortunately invalid. I've been running Leap 42.1 for just
a week (switched because of 13.2's recently-introduced bug
960258 for which I couldn't wait for a solution) and I've already come across
stuff like bug 965240 in Leap. The simple solution is a file from the
unofficial OBS devel:languages:perl as the version shipped in Leap hasn't
worked with its intended target since 2014-Feb. The "official update" version
in 13.2 worked fine too, but it was downgraded to the dead one during the
13.2->42.1 "upgrade".

https://bugzilla.opensuse.org/show_bug.cgi?id=965240

Very minor bug, yes, but a distribution can't be said to "work perfectly" if
standard user applications (GnuCash) don't run on it out of the box.

Don't get me wrong, I really *like* Leap so far (especially since it solved my
LUKS problem in 13.2, thank you very much) but there are things that an
ordinary user MUST go outside the official repositories for. Real life can't
wait for an official patch to be released. So anyone who does actual ordinary
useful stuff on Leap must of necessity be "un-pure".

Ralph
--
"Security is a chain within the infrastructure and is as secure as its weakest
link. It is not a product nor a series of technologies but a process of
solutions measured against the business needs of the
organization." -- Walter S. Kobus, Jr., CISM CISSP IAM
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References